The Things Network and MQTT In Nodes Problem


I have been using Node-RED to process payloads from four SenseCAP LoRa nodes connected to The Things Network(TTN) without problems for sometime now (12 months +). Today I added a new sensor, acquired a new MQTT API key and tried to add it to my flow with a MQTT In node. As soon as I deployed it all my other MQTT In nodes disconnected but the new node reported as connected.

I tried some troubleshooting and in the end, I deleted all the existing TTN API's and created new ones, added them to my flows and after some juggling managed to get the four existing MQTT nodes and the new one reporting as connected.

I then added a function node to my new sensor flow to extract the desired payload for insertion into mariadb and then tried to connect this function node to an existing mysql node. As soon as I did this all my existing MQTT In nodes disconnected from the TTN. As soon as I deleted the connection from the new Function node to the existing mysql node all MQTT In nodes reconnected.

Sorry I don't get it. Can someone point me in the right direction please? How does connecting a function node to a mysql node affect a MQTT In node?.

MQTT In -----> Function------->mysql

Perhaps you are crashing Node-RED? Have you checked node-red logs?

Are you doing full, flow or node deploy?


Please tell us how you run node-red (Node-RED version, NodeJS version, etc.)

I reckon you nailed it. I believe I was doing a Full deploy(didn't take much notice to be honest) but now I seeing and using the Restart flows option all MQTT In nodes are connected and receiving payload.

Thanks for pointing this out. Will make a note of it and only update modified flow/nodes in future.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.