UI LED now available for Dashboard 2.0

HI All, it had been a very popular request, and is the most popular third-party widget for Dashboard 1.0, so, I spent last night and this morning building out UI LED for Node-RED Dashboard 2.0:

I've just published it to the Node-RED Catalog: node-red-dashboard-2-ui-led (node) - Node-RED

Please give it a go and let me know how you get on. Happy Dashboarding!


On one of my systems it works perfectly, but on another it is completely invisible. If I inspect the space where it should be it is there and I can't see anything wrong. Both systems using latest node red and D2 and nodejs 20. Nothing in the log and no errors in browser log.

I am not proficient in CSS, any suggestions on what I should look for in the inspect details?

1 Like

When you say it is there, do you mean in the HTML DOM? But renders invisible in the actual Dashboard?

That is odd.

If youre able to reproduce with a small flow, please do open an issue, and I can take a look

Same issue here. Ticket created at The LED does not show up on the dashboard. · Issue #2 · FlowFuse/node-red-dashboard-2-ui-led · GitHub

Minor detail: the GitHub link on the page @flowfuse/node-red-dashboard-2-ui-led points to https://github.com/flowforge/node-red-dashboard-3rd-party and not to https://github.com/FlowFuse/node-red-dashboard-2-ui-led

Thank you!

1 Like

Minor presentation niggles:

  • How come ui-led appears in palette group ui rather than dashboard 2?
  • The widget in the palette is uncoloured, not what one would expect from an LED.
  • Once dragged into the editor it is unhelpfully gloomy.
  • In the User settings popup, Dashboard 2 has no "-2" but @flowfuse/node-red-dashboard-2-ui-led does have.




It is all at default settings, just placed on a page. I wonder if it is a sizing issue, on an old tablet that I have I can see it as a tiny red/green dot only a couple of pixels across, though the same dashboard shows nothing on PC or phone. On the PC I did force a full page refresh to no avail.

I am not seeing those problems


Possibly try a node-red restart and clear browser cache and refresh page.

Hmm, well thats very bizarre. Something hasn't gone to plan with the publication of the node...

Restarting Node-red has resolved the colour scheme and grouping points.
Problem maybe arose because I installed dashboard 2 and ui-led at the same time?

Quite possibly - although still odd. If Dashbaord 2.0 is installed first, then it shouldn't occur. The ui-led utilises some locales strings from Dashboard 2.0 in order to work out which category it's meant to live in, and colour scheme, etc.

I have been able to product this, although annoyingly not locally. This isn't an issue with ui-led, but the underlying Dashboard 2.0 codebase which is struggling to load third-party widgets. Just tried ui-webcam too and it's the same problem.

Although I know that @sumitshinde-84 mentioned he tried ui-webcam on FlowFuse after publishing, and it worked okay. For me, it isn't - it's all very odd.

Summary of problems detailed here: The LED does not show up on the dashboard. · Issue #2 · FlowFuse/node-red-dashboard-2-ui-led · GitHub

Why it's happening on some instances of NR and not others, I'm yet to decipher. This is a core Dashboard 2.0 problem, rather than ui-led specifically.

Hi @joepavitt, I have also tested and found that it works perfectly only if Dashboard 2.0 is installed first. If anyone has installed a third-party widget before, they need to uninstall/remove that package. Afterward, they have to install Dashboard 2.0 first, and then the widget works as expected.

Here is the video

I did already have it installed so that is not the full explanation.

Yeah, I had D2.0 installed first, but still see the problem. Tis very odd.

Yes, I understand. It's not solely about installation; I was simply trying to share how things are on my side so that it will help @joepavitt understand the problem more accurately, going beyond just the installation steps

Performing a clean install of Node-RED, then DB-2 and finally LED-2, and clearing the cache of the browser, solved the issue on the RPi5.

Thank you for the hint!

I just had to restart Node-Red on my RPI and the UI LED worked.

Just a note of concurrence - the node-red-dashboard-2-ui-led widget was invisible until performing a Node-RED restart. Pi4, node 18.19.1, npm 10.2.4, Armbian 24.2.1 jammy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.