Unable to install NODE-RED Linux Mint 21 XCFE

we are trying to put node red on a Intel NUC Core i3 device.
Put Linux Mint 21 on there as base OS, tried to install using the Bash script and its refusing to install node-red core.
Node js 18.15.00
npm is version 9.5 ish, not at machine at present.
it runs through to the end of the install and asks if we want to set up control but then fails to load Node-red
any ideas?

What fails - what errors do you see?

None theres no errors come up, just that node red isnt there when i do the command node-red-start.

Dont have machine on at mo , just wondering if it a know issue?

Did you attempt to start node-red? What command did you use to "fire it up"?

Doesnt sound like any issue I know of.

You should post details once back at the machine.

sorry edited message .
Ive installed node-red on about 20 different machines, windows, Linux (debian) and pi's and Ive not seen it do this before.

This isn't my screen shot it just to explain, it gets to this point then Install Node-RED core and i get a red X
it goes through the rest of the install , then to a command prompt, i type node-red-run as usual , but its not installed node-red.
Tried 4 times now re running the script and rebooting in between just to make sure.
Ill try to grab info from the NUC unit tomorrow as its in use at mo.

try adding --node16 to the end of the install command to force it to install nodejs 16...
(Or are you running under n or nvm to manage the version of Node ?)

You said at the start

But the install script thinks you have 10.
What do these show?
which node
node -v
apt policy nodejs

@dceejay, did that , then it said Use nvm lts
, so i listed the version of lts , found the latest one and installed that with nvm install 16.xx and it then went through and installed.
No idea why it was nvm, usually its npm.
@colin, the image was for reference , just to explain where i was having the issue

Thanks for the help!

Those are completely different. nvm is Node Version Manager which is a tool that allows you to have multiple versions of node installed at the same time (hence the confusion over which version is installed in the image you posted). So for some reason nvm had been installed on that machine. It is generally recommended not to use nvm unless you have a good reason. Since you did not know about it you presumably don't have a reason. You may well have ongoing problems if you leave it installed, as the other versions of node are probably still present, and which version you get depends on what else is going on. You might well be better to get rid of nvm (I don't know how to do that, so you might have to search for that) and start again.

@Colin Colin, ignore the image it was just to show the point where the bash script failed , as i said it wasn't from the machine just for info.
It looks like its in the Linux mint 21 distro XCFE , as this is a one off project I'm not going to change the nvm , there's a high probability this thing will end up sinking to the bottom of Loch Ness anyway, but good to know.
for future me or someone else !
Removing NVM from linux Distro

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.