Uninstalling node-red-contrib-ui-time-scheduler fails

Hi, when I try to remove npm remove node-red-contrib-ui-time-scheduler in (home)/.node-red it fails:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'start',
1 verbose cli   '--cache',
1 verbose cli   '/data/.npm',
1 verbose cli   '--',
1 verbose cli   '--userDir',
1 verbose cli   '/data' ]
2 info using npm@6.14.6
3 info using node@v10.22.1
4 verbose config Skipping project config: /usr/src/node-red/.npmrc. (matches userconfig)
5 verbose run-script [ 'prestart', 'start', 'poststart' ]
6 info lifecycle node-red-docker@1.2.1~prestart: node-red-docker@1.2.1
7 info lifecycle node-red-docker@1.2.1~start: node-red-docker@1.2.1
8 verbose lifecycle node-red-docker@1.2.1~start: unsafe-perm in lifecycle true
9 verbose lifecycle node-red-docker@1.2.1~start: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/src/node-red/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
10 verbose lifecycle node-red-docker@1.2.1~start: CWD: /usr/src/node-red
11 silly lifecycle node-red-docker@1.2.1~start: Args: [ '-c',
11 silly lifecycle   'node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"' ]
12 silly lifecycle node-red-docker@1.2.1~start: Returned: code: 1  signal: null
13 info lifecycle node-red-docker@1.2.1~start: Failed to exec start script
14 verbose stack Error: node-red-docker@1.2.1 start: `node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"`
14 verbose stack Exit status 1
14 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
14 verbose stack     at EventEmitter.emit (events.js:198:13)
14 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
14 verbose stack     at ChildProcess.emit (events.js:198:13)
14 verbose stack     at maybeClose (internal/child_process.js:982:16)
14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
15 verbose pkgid node-red-docker@1.2.1
16 verbose cwd /usr/src/node-red
17 verbose Linux 4.15.0-121-generic
18 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" "--cache" "/data/.npm" "--" "--userDir" "/data"
19 verbose node v10.22.1
20 verbose npm  v6.14.6
21 error code ELIFECYCLE
22 error errno 1
23 error node-red-docker@1.2.1 start: `node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"`
23 error Exit status 1
24 error Failed at the node-red-docker@1.2.1 start script.
24 error This is probably not a problem with npm. There is likely additional logging output above.
25 verbose exit [ 1, true ]

It seems like it's trying to invoke some commands with Docker but the Node-RED is running locally.
Cheers.

Looks like docker causing issues again.

If you aren't using Docker, it looks like you have some docker stuff in your config that you will need to unpick.

Could you point me, where I should be looking? Cheers

Sorry, I don't use docker for Node-RED (nor at all if I can help it).

At a guess, I'd say that you used a Node-RED docker install script to install Node-RED? If so, you may have to uninstall that first. Then you may well have to install node-red from scratch.

I don't use Docker for Node-RED on this machine either, so I'm a bit confused. I'll try to search through the system to find anything to do with node-red and docker.

Removed Docker from my system, run bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) to update NodeRED from 1.2.6 to 1.2.7 and node-red-contrib-ui-time-scheduler disappeared from my system. Not sure, if this is what helped but no errors anymore.

1 Like

Looks like, after system reboot, the packages appeared again together with the issue. Spending good time reading logs, I found there was a deprecated package: node-modbus. I think, this is solved now.