Upgrade node-red on windows

that is not correct

Look again

Yes sorry, I see that I was wrong but after that I run the correct command.
The results is nothing again

....do you think that is better to remove node-red completely and re-install?

Not sure, I think the npm prefix is not correct, the following command should return you C:\Users\Nu!Reha\AppData\Roaming\npm:

npm prefix -g

If not, it can be set with the command

npm config set prefix C:\Users\Nu!Reha\AppData\Roaming\npm


npm install -g --unsafe-perm node-red@latest

Please be specific. Show us exactly what you entered and what you seen.

And show us the startup log.

No, but worth a try at this point.

Great, it works!
npm prefix -g returns C:\ProgramData\npmglobal so I set the new path and now node-red is updated!

Thank you so much :heart_eyes:

The results was exactly the same that with the wrong command.
With the @GogoVega suggestion now is update

I see you have at some point changed npm global location - you should delete all node_modules from the old location to avoid this sort of thing in the future..

i.e. if you are now using a machine global path (e.g. C:\ProgramData\npmglobal) instead of a user global path (e.g. C:\Users\Nu!Reha\AppData\Roaming\npm\node_modules) then get rid of C:\Users\Nu!Reha\AppData\Roaming\npm\node_modules completely.

PS: I use a machine path for global modules too (makes more sense)

I honestly don't know. I installed Node-Red a few years ago, can't remember when, and I just follow the official instructions for Windows.

In environment variable I have nothing about npm in System variables - Path (I don't know if this is the right name in english, I'm sorry) but C:\Program Files\nodejs\.

Instead, I have C:\Users\Nu!Reha\AppData\Roaming\npm in User variables - path.

What I have to change avoid this problem in future?

Sorry; I'm very late to the party.
Are you aware that there's a Windows Installer for Node-RED available?
As we're still in (late) beta testing, I'd be very interested how this installer is handling your issue.
Could you please give it a try and report back the result?

Thank you in advance! Would be highly appreciated!

Hi @ralphwetzel
Yes, I can to try it in another machine to avoid to get worse the situation of node-red in my computer :sweat_smile: :rofl: :slightly_smiling_face:

:wink: You could as well just launch the installer and let it walk through the actions where it tries to analyze your system (without actually doing any installation) - to check if it is able to detect things properly.

It detects the newer version of NodeJs I installed yesterday e suggests to me to keep it.
Then it detects the newer version of Node-Red (3.0.2) e suggests to me to keep it and that the Global installation was in C:\Users\Nu!Reha\AppData\Roaming\npm

Finally....I tried to install :sweat_smile:
At the end I start Node-Red and all my flows disappeared.
I think they are still here.....somewhere :rofl:

Anyway I exported all before the installation and everything it's fine

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.