Who killed Alexa?! - "Authentication failed: "no body""

Hi guys,

since few days my Alexa event node temporarily stopped working stating the following error message:

"Authentication failed: "no body""

Usually it helped to either restart all flows or, as a last resort, restart the whole Node-Red integration (I´m using Home Assistant). But since today even this has no effect anymore. I´m using the


palette but also tried different other ones but it´s the same situation. Anyone know who killed Alexa and how to revive her?

I've got exactly the same issue/problem - exactly the same error message with my daily weather forecast.
Screen Shot 06-04-21 at 04.58 PM

Everything has been working fine for the last 3 or 4 weeks.
I've tried various things to try to resolve it - all have failed.
I've even installed the nodes on a Raspberry Pi that didn't have any of these nodes - still dosen't work

I'm using the original node-red-contrib-alexa-remote2 and its working "fine" - well, as well as it always does :slight_smile:

1 Like

Thanks Simon - I'll try that out this evening.
Just out of interest - which version are you using??
Screen Shot 06-04-21 at 05.26 PM

Saw a lot of people having problems earlier in the year switching to cakebaked etc

I wasn't have any more than the usual problem of having to init it every time a prime number occurs in UNIX timestamps :slight_smile: so I just stayed with original

Tried it with both of the old pallets "node-red-contrib-alexa-remote2" and "node-red-contrib-alexa-remote2-v2". Unfortunately absolutely no change in the situation :frowning:

Phew i thought i broke mine this week.. so glad it wasnt just me getting this.. im using the Cakebaked version..

Well this is really weird !!!
My daily weather forecast delivered via Alexa worked this morning.
The Node-RED flow hasn't been working all week, then burst into 'life' this morning.
I've just looked at the flow and it had a green success light against the Alexa node, yippppeee...
Unfortunateley, after I deployed the flow I'm getting the 'Authentication failed' message!!
Oh well that success was short-lived.

I've just removed my old version of 'alexa' and tried 'node-red-contrib-alexa-remote-fork' - that gives the same problem and error message.

I've tried all sorts of combinations of 'Fresh Authentication', 'Refresh Cookie' before doing 'Initialise'.
I did notice the (optional) User Agent box is blank. What have other people put in there?
Screen Shot 06-05-21 at 08.38 AM

Solution : [#22 (comment)](

Was working great and now won't authorise on 3456 · Issue #22 · cakebake/node-red-contrib-alexa-remote-cakebaked · GitHub


1 Like

BRILLIANT - thanks for sharing this solution.
I just followed the instructions in your link and it worked like a dream for me.

I'm using 'node-red-contrib-alexa-remote-fork' and the instructions worked fine for that node.

Thanks much @Varguit - Looks like they already fixed it themselves. After re-installing the cakebaked version, the missing entry to alexa-remote.js was already made and the node initialized smoothly again :smiley:

Yah did the solution and that worked for me too using Cakebaked. Many thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Just had this issue but the fix worked for me :slight_smile:

I'm using the original node-red-contrib-alexa-remote2 node