2.0.1 Labels in editor UI missing

Hi there, thanks a lot for the graet development work!

I made my tests with 2.0.1 with a new installed copy of my flows; everything worked fine.

Then i made the upgrade in the productive environment. No functional deficites, but there is something wrong with the language settings. All labels in the editor UI have no teaxt content (e.g. the deploy button is called "deploy.deploy". Changing the language and restart made no difference. Environment variable LANG ist set to de-DE; OS is MS Windows (germam), that all worked fine beforee the upgrade.
Any idea?

What browser are you using?

Have you enabled Monaco?

Can you see any errors in browser console?

How did you install node-red?

Have you cleared browser cache?

Hi Steve, i guess your questions lead into the right direction:
a) i tested with Chrome and Edge; same behaviour.
b) Yes, Monaco is on. But without Monaco i have the same issue.
c) No error messages at all
d) Installation was done with "npm install -g --unsafe-perm node-red" - as for many release changes before
e) BUT: Yes, Browser cache and cookies have been cleared. No difference. But working on your questions i found that the issue disappears when i use an inkognito tab or a browser on a brand new machine. Is there anything else to clear or to set?

Could you open devtools, see what value is in local storage under the key "editor language"

Could you try changing language in node-red settings (under hamburger) & refresh browser, then back to original.

when i opened the dev tools there was only one entry for auth-token; no "editor language". Setting the editior language to german created an entry "editor-language=de". Turning to english changed the key to "en-US". Changing to browser defaults clears the entry. But no change in UI when refreshing the browser.

by the way: i switched off all ad blockers and cookie tools in the browser to avoid any conflict.

I've installed node red in another instance from scratch. Working with the same browser; all labels are correct. So i think the browser and client settings are no longer in focus. It seems to be a problem coming up from the upgrade process.

Now i started the non-functional instance with a different port (1881 instead of 1880). Everything works fine. Unfortunately this is not a solution; i cannot change all clients and contact all users.

This will be a browser caching issue. Are you sure you've completely cleared the cache for the page?