Adding a Node-RED-Dashboard UI widget node makes everything else disappear

When I add an UI widget, in my case node-red-node-ui-table, everything that existed before on the dashboard dissapears (theme also returns to the default one), even my side bar menu.
Only the widget is shown:

I can't figure out what is the problem and I am stuck because of that. Please let me know if you need further information about this issue.

What versions of node-js, node-red, node-red-dashboard are you running?

Are there any errors in the browsers console?

First question:

Second question:

This happens with any widget type node, also tried with Upload UI Widget. Maybe I am doing something wrong or I miss a setting.

Export your flow and attach it to a reply so someone can take a look at it

In order to make code readable and usable it is necessary to surround your code with three backticks (also known as a left quote or backquote ```)

   code goes here 

You can edit and correct your post by clicking the pencil :pencil2: icon.

See this post for more details - How to share code or flow json

Can you walk me thru the steps you take to add the table widget to your flow and how you configure it? Please be detailed so I can try to recreate your steps.


  1. I installed it from here:
  2. I drag it from the "dashboard" section and put it into my flow:
  3. I set its group and click done + I connect it to the postgres node
  4. I press deploy and my ui goes from picture 1 to picture 2



*If I disable the widget node after being shown on the ui, my ui goes to (see picture below). The only way to go back to my normal ui (picture 1 from above) is to redeploy from cmd

Can you go to the editors right sidebar (where you see debug msgs) and click on the `dashboard' tab and expand all tabs and take a screen shot of it.

Also attach a debug node (set to display the complete msg object0 to the output of the postgres node and show me the results.

Following your instructions I can not reproduct the issue.

The output of debug node:

The widget: I don't really care that the output looks like this right now

Command used to start the server:

I guess since the problem can't be reproduced maybe it has something to do with my files?
Does it matter from where do I start the server? Is there a difference if I start it from /bianca.cernat or from /bianca.cernat/.node-red-1881?

Is tehre a reason you are running using port 1881 instead of 1880?

I have another node-red application that is running on 1880. I use this as a workaround because of the fact that node-red is not multiuser intended.
Also I get the same behavior on port 1880

All I can thnk of at this point is it might be an issue having to do with Windows which I can't test out since I have a MAC and some Pi's.

@Steve-Mcl any ideas Steve?

I identified what generates the problem:
When starting the server with the command

node-red -p 1884

everything works fine.
When I rename my folner from .node-red to .node-red-1884 and start it using

node-red -p 1884 -u c:.node-red-1884

What I describe earlier happens.

I assume you mean c:/node-red-1884 or c:\node-red-1884?
c:.node-red-1884 is not valid is that a typo?

node-red -p 1884 will be using a different folder (with different node_modules installed) to node-red -p 1884 -u c:/node-red-1884

So this basically means what you have installed in c:.node-red-1884 (wherever that is) has an issue where as the default .node-red folder (probably in c:\users\YOURNAME\.node-red) does not!

They are both the same folder I just rename it from .node-red to .node-red-1884, so they should use the same folder.

No, not entirely sure what you mean.

If you want to load the flows and installed nodes of .node-red then node-red -p 1884 will use .node-red

If you want to load the flows and installed nodes of .node-red-1884 then node-red -p 1884 -u c:/users/bianca.cernat/.node-red-1884 will use everything inside .node-red-1884!

If you want to run both folders at the same time, use different port numbers...

node-red -p 1880 -u c:/users/bianca.cernat/.node-red    
# NOTE: this ↑ is just the same as entering   node-red  
node-red -p 1884 -u c:/users/bianca.cernat/.node-red-1884

Both will run on separate ports and you can test both at the same time

Ok, so. I think I resolved the problem.
Before I was running it with the command that was not specifing all the path

node-red -p 1884 c:.node-red-1884 yes this really worked, i don't know how

I tried to run it with

node-red -p 1884 -u C:\Users\bianca.cernat.node-red-1884

and it worked.

Thank you for all your explanations, they helped me a lot in resolving my issue and gaining more knowledge about how node-red works!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.