Alexa 'On Device Activity' not working

I moved away from Alexa and have migrated over to SIRI :wink: ... the homebridge node works great for me to manage all my devices in the house with voice commands ... and again ... all local .. no cloud :wink:

negative side ... i have lots of alexa devices in my drawer :frowning:

Thanks Sean for this creative idea - so simple, so effective and so very clever.

1 Like

Hi Sean,
Just taking your creative idea a stage further with two virtual dimmable lights (using your technique).


The 'Command' VSH node deals with commands like "turn on, turn off laser" etc.
Now for the clever bit.
The 'Location' VSH node will set a variable from words like... "I'm in the kitchen", "I'm in the lounge" or just "kitchen" or "lounge". Then I should be able to send a string to the appropriate Echo device.

I had to set the increments to 5-steps as my eyesight and fingers let me down (old age thing) when trying to set the brightness levels in the Alexa app.

The above flow will direct my weather report to the appropriate Alexa device.

It sounds like @dynamicdave might need them he only has 8 :wink:

I meant that some of your topics look like Tasmota devices, (not sure if this was just for testing), but you do know that they can work directly with Alex without a virtual node ?

Quick update for anyone trying out Sean's @smcgann99 creative Alexa solution. Here's an example...


I'm using various brightness levels to turn On/Off some SonOff S20's devices that power a laser, a computer & access point in our lounge and computer in my office.

When you create the Alexa Routine you need to make sure the Power setting is On in both situations.
I found to this out to my cost in wasted debugging time that if the Power setting is Off then the brightness value is not sent - which confuses the decoding in the Node-RED flow. It seemed natural to set the Power setting to Off when I wanted to turn, say, the laser Off - but be warned, use On in both situations.