Alexa Remote2 event nodes not working (again)

I know at least a few of us use this node, it seems to be broken again.

There are lots of reports on GitHub but no solutions.

Has anyone here found a fix ?

Same problem here but no solutions ...

I'm using alexa-remote-fork version 3.11.3 and that is working fine for me.
Just checked the various Alexa nodes, this version was updated 3-months ago, so might be worth trying.

Same issue here
@dynamicdave The issue we are having is that we are not getting any output from


Are you able to receive output from yours?

Yes. Just asked her "Alexa, what is the time".

In Italy "applestrudel" - on device activity - don't work ...... (test in this moment)

Here are some more details of my setup - I initialise the Alexa node every 6-hours with this flow...

At 7:00am each morning I get a weather report delivered to the Alexa Echo Dot in my back bedroom.

Ok, to be clear, "applestrudel" works fine in every node but not on device activity;
this node don't works, the others yes ....

I've not tried Applestrudel recently, I just thought as it had been updated just 3-months ago it would have all the latest fixes. I'll see if I can find a spare RPi to test it out (as I can't install on my existing system as there is a name conflict and I don't want to mess around with my working system as I'm sure I'd break it).

Thanks for checking Dave :smiley:
I assume it's this one node-red-contrib-alexa-remote-fork which hasn't been updated in 3 years :face_with_raised_eyebrow:

Just swapped out applstrudel for alexa-remote-fork and events work again.

If anyone else wants to try -

$ cd .node-red/
$ npm remove node-red-contrib-alexa-remote2-applestrudel
$ npm install node-red-contrib-alexa-remote-fork

You will probably see a warning

npm WARN deprecated querystring@0.2.1: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.

Not sure what other fixes it must be missing, so will need to test out other nodes.
But at least it should be fixable by reverting some of the changes in latest applestrudel.

Will post issue with this info on GitHub.

1 Like

Would it be possible for someone WAY SMARTER than me to compare the code for the working On Device Activity Node in Fork to the same node for Applestrudel to see what is different and causing issue? I don't have the knowledge to do so.

This has also worked for me to restore getting Alexa commands :slight_smile:

Quite wierd that an older fork still works! (just read the github comments so now understand its using an older protocol/access method that still works)

1 Like

Yeah, I haven't tested all other nodes yet, but haven't noticed any issues so far. :shushing_face:

Seems like it identifies the problem so should be fixable in newer versions at least.

Slight problem using node-red-contrib-alexa-remote-fork - the flow I use to send commands to my Alexa device no longer works

How have you configured that node??

To direct the message to a specific device, I use this...

You can also direct the message to a device via msg.destination or a variable...

What happens if you try a very simple test flow, like this..

My speak flow still works fine

This flow uses NR to send a command to a device as if you were speaking to it


Text commands was add in

So I doubt alexa-remote-fork version 3.11.3 will have it.

Is slightly weird that it is showing in the config though.

I did think that might be the reason.:frowning:

I'll temp have to go back to gluing an earpiece close to the microphone input and using my old text-speech flow

You can use node-red-contrib-alexa-remote2-applestrudel instead of alexa-remote-fork, only changing a bit of text in the file alexa-remote2/alexa-wsmqtt.js line 174, change this.connectType2() to this.connectType1() then restart NodeRed and "On Device Activity" and even "Routine Text Command" should work again.


Works! :+1: ..... Thank you!