Alexa 'On Device Activity' not working

I meant that Device Activity is not workingSchermata del 2023-10-01 17.25.58

If I manually feed a message and then re-authenticate with Dave's flow, the activity on the device works for a few minutes

1 Like

As an experiment, disable your trigger node and redeploy

Then stop/restart Node-RED

See if it works for more than 2 or 3 messages BUT DO NOT redeploy while you are testing

I currently believe that the fault only appears if it is initialised more than once after a Node-RED restart.

1 Like

Just tried that - it only performs or responds to 3 Alexa commands before she stops reacting (hiss, boo).

How about disable your existing Init node

Add in another one - do not connect it to anything - make sure it's set to auto init

stop/restart Node-RED - DO NOT do any deploys while testing

What happens?

1 Like

At my end - I ran a test sequence of my automated Simon says 1 to 69 over 20 minute period

All worked prefectly - after message 53 - i re-initilised - it stopped working at message 58 and only restarted at message 63

At my end, It definitely seems to work as long as I never re-initialise

1 Like

Hi Simon - I agree with your findings.
It seems to be much more reliable when doing that - tried it over 10 times, all worked.

Note: My Alexa node is set to refresh every 3-days (which I think is the default).

I have mine set at 0

What does '0' mean - never do a refresh??
Just changed my setting to '0' to see what happens.

AFAIK 0 means never refresh.

Don't get me wrong - its still broken - but I think we might be zeroing in on what causes it to go into failure mode :slight_smile:

before all this happend - I was like you - used to send an init in every few hours

And I think this explains why some people are having the issue and some people not

So I'm now running my Alexa node in a separate instance that only has one flow (which I'm locking) and I use MQTT to send received events off to my other NR instances that need the data.

Hopefully, this will act as a working workaround until a proper solution is found by the wizards :slight_smile:

Of course, I think I've found a solution about 10 times in the past few weeks so I'm probably wrong about this one as well :slight_smile:

But it currently matches up with cause and effect :slight_smile:


Well it certainly seems more reliable if I don't 'init' it again.
Certainly need to stop/start Node-RED.
Performed over 24 successful commands at the time of writing this post.

EDIT: Over 1hr and 60+ commands and the 'OnDevAct' is still working.

EDIT: Just noticed an update for the node has been posted.
EDIT: 2 hrs and still working fine.


Watching last night's strickly at the moment but will test later

  1. removed Alexa event node and links

  2. recreated another Alexa event node,connected to each switch node like the previous one,

  3. disabled refresh with 0 in alexa account,

  4. restarted NODE-red

and everything has been working correctly for about an hour.

1 Like

See my comment on GitHub

1 Like

Disabled refresh and installed latest version - so far so good :wink:


Just checked this morning - 'OnDevAct' is still working. That's over 13 hrs of use.
So it would seem that performing an 'init' is in some way related to the instability problem.

Edit: Just checked again - still working - that's nearly 18 hrs.

Edit: Nearly a whole day (24 hrs) of use in my NR flow - still working.


I also for about 9 hours ,everything works smoothly.

I have the same problems again :exploding_head:

Same here - my 'OnDevAct' has stopped working this afternoon !!!!

1 Like

Yep - confirmed -stopped in past few hours

Reported it on Github


Just to jump on the bandwagon - also not working here :roll_eyes:

1 Like