Alexa 'On Device Activity' not working

do you still have hopes that applestrudel will come back to work again? .Do we put a stone on it? (typical Italian quote) :sleepy:

Your guess is as good as mine

1 Like

I get the feeling Amazon are actively breaking it :wink:

I notice the Alexa web app has been retired too, I used that a lot :face_with_raised_eyebrow:


Any news on getting the Alexa node to work again??

I tried performing a 'Fresh Authentication' and got sent (as usual) to the URL: localhost:3456
The page I was sent to has changed and doesn't offer the option to login via my Amazon account.
Have other people on the forum seen this, and if so, how have they managed to Initialise the node?


Usually trying 3 different browsers with all the possible variations in IP address , twirling around 3 times and sacrifice of small animal usually works in the end

Not tried it recently so maybe more steps involved now :slight_smile:

Dave - see post above yours :wink:

There's a bit of progress :slight_smile:

Not fully got my head around what's possible and what's not but it's better than nothing :slight_smile:

I have been using a similar work around with routines and a virtual device. The virtual device triggers the "alexa other" node, setup to query the last activity. In that message you can see what was said and which echo was used.

This WAS working fine until I just checked today, and its also now broken -

This node now returns an error "Error: No JSON at handleR"

A catch node reveals why -

Website Temporarily Unavailable


website temporarily unavailable

A big thankyou to amazon :roll_eyes:

Updated node is now available which fixes the above problem :slight_smile:

The fix is nearly here :slight_smile:

I just tried bodging my system with the latest changes from the alexa-remote dependency and its working again :slight_smile:
Hopefully available publicly within a few hours :slight_smile:

Works for me (at the moment).

Looks like the update has been released as V5.0.45

I think there was a release v5.0.44 quickly followed with v5.0.45
v5.0.45 is working with my NR flows again.
Many thanks to everyone who contributed to sorting out the issue.
I can now turn items On and Off again in my home.

1 Like

Hopefully for a long time :slight_smile:

1 Like

it doesn't work here , i updated to the new version ,i updated the applestrudel cookie . i get this:
Schermata del 2023-10-29 08.51.59

That looks like a different problem. :frowning:

I suggest that you open up a new thread about it

1 Like

says to change the credentials in the settings file of nodered , I changed , the 'warning no longer appears but applestrudel does not work

V5.0.46 has been released with further improvements


Now it seems to work , however I still can't activate the groups. very good again at troubleshooting!

I no longer get the cookie as an output from the Initialise node. Is there some change I should be looking at?