Alexa 'On Device Activity' not working

clear the browser cache

I've been using v5.0.46 successfully for a few days.
One thing I've noticed is I have give a verbal command twice (as the first doesn't produce a response).

Note: I'm using BluePrints and filters the response in Node-RED to trigger my home devices via MQTT.

All commands or just some?

Just the ones with BluePrint skills?

FYI Mine seems to be fine - every time I test - it works


Ummm - seems to be just the responses from BluePrints.
I need to check the "filters" I'm using in my Node-RED flow as I suspect the format of the response may have changed and my "simple" flow (ha, ha) is not working quite right.

1 Like



Wow even with all those link nodes, its a rats nest (OCD alert!) :wink:

1 Like

That's unkind (wink, wink) - I'm trying my best under very difficult circumstances.

1 Like

Thank you, that worked

Currently experiencing this behaviour
I say something - no activity - I say something - no activity - I say something - I get all three activity messages in a row

Other times - works fine

What are you lot experiencing at the moment?

It seems to work every time for me, but there does appear to be a longer delay before the node triggers.

I have the same behavior , requests seem to queue up and then after a variable amount of time I get a response.

Can you (and anyone who doesn't seem to have the same problem as myself and people like @franz) please try this sequence


Monitor the output of the activity node msg.payload.description.summary

Pin it open so you can see it each time

Say "Alexa Simon says one" - check that the activity node outputs this

Wait 15 secs - then do "alexa simon says two"

keep monitoring the output and check that each message is detected after it has been spoken

Do this for two minutes

Do you see all messages shortly after you've spoken or do some of them not arrive but then later arrive in a bunch?

Seems OK to me -

1 Like

Grrr. What an annoying situation. :frowning:


Seems OK to me also. Very annoying for Simon et al

What's even more annoying is that I thought practically everyone had the same problem so I was just waiting for the node devs / Amazon to fix it!

I was just ignoring people saying it was OK as muggles who hadn't tested properly :slight_smile:

[edit] #Idea - I'll order a new Echo (as Black Friday) and see if that makes a diff

No problems here.

Have you tried:
"Alexa, stop bloody buffering" :slight_smile:

1 Like

:magic_wand: Hey I'm no muggle :mage:

I just did and interestingly they didn't respond - not even an OK!!!

1 Like