All injector buttons greyed out

I was experimenting with dashboard elements and global context on NodeRed 3.0.1. I was using the injector node buttons to simulate various actions. At some point all the injector buttons (across this and all other flows) have been greyed out. All the debug nodes are also grey (and nothing is showing in the debug panel).

I tried restarting NodeRed, but that did not make any difference.

Any idea what this means and how to resolve?



Are you sure you clicked 'Deploy'? that is the only (frequent) reason I can think of for both set of buttons to be disabled.



Have you enabled stop/start in settings?

Under the deploy menu, do you have an entry named "stop" or "start"?

I pressed the restart flows button:

And got the message successfully restarted flows, but the result is the same.


and the Dashboard is still working...

I got it working again!

I have noticed that the node-red UI doesn't always notice when the backend goes offline. It is good that the elements on the web page don't cause the whole page to reload when they change, but sometimes I make several changes and it doesn't seem to work quite right. Then pushing F5 to reload the browser shoes a Bad Gateway or not found error.

In this case, however there is an additional factor - Docker with Visual Studio Code.

When I run docker docker-compose up -d, VS Code pops up a message asking if I want the NodeRed port forwarding to my laptop, where I can connect via localhost. In this case I restarted docker-compose and did not use the link proposed by VS Code. I carried on using the old web page (i.e. I did not reload the page).

Bottom line - it would be very useful if node-red were to have an alert when the back end is not reachable.


I get this message at the top right of my browser on the ui page when the server is not available.

Not seen that.

I stopped the docker container and waited a minute - I can't see any connection lost message:

This is using Safari 15.5.

The Dashboard somewhat confusingly shows:

After starting node-red again - I have to refresh the dashboard page to get it to load.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.