Imported flows/


I installed node-red on a other Raspberry pi and from the old pi i did an export of all flows. After import of the flows on the new pi the débugnode is dead. They could be clicked on or off, but that does not work anymore.
Do i have to activatiecode something?

Thanks for your help

Hi @pgas37. You should not need to do anything to enable the on/off button on debug nodes on a fresh installation.

How did you install Node-red?

Try deploying the flow, clearing your browser cache, restarting the Pi and reload. Does it work now?

I installed node-red using the instructies on the node-red website. No probleem or error.

Clearing the browser and restart of the pi did not help.


Can you post a screen capture of your browser showing the editor?
Please include a flow with debug nodes and the URL address bar.

as requested, a screen-capture

If you press the greyed out button to the right of the debug node, you should see it go green. Then the flow should prompt you for a redeploy.

And what happens if you place a new debug node?

A suggestion from
In a terminal window

cd ~/.node-red
npm update

Can you also share the version of Node-red you have (at the bottom of the hamburger menu) and Node.js version (npm -v)

I excecuted the commands:

Node-js version = 3.02

That is exactly the thing that not happens: not going into green

Node-RED is showing the warning flag @ upper right corner, third icon.
What does it tell you?

here is a screen-capture of the warning-flag. Some other flows are imported, but tehy all are disabled.


Well - that's most probably the cause of your trouble:
It doesn't help to disable flows with missing nodes.
If a (single) node type is missing, NR stops all flows.
As the flows aren't running, the nodes aren't running; your button press is not processed, the status change not propagated.

No it isn't. That may be the node-red version, except it would be 3.0.2.

The nodejs version can be seen by using
node -v

As well as answering @ScheepersJohan's questions, can you stop node red and start it again, and post the full startup log here. Copy/paste please, not screenshot. Stop and restart using

Also open the browser console (in your browser, google if you don't know how to do that), refresh the page and see if any errors shown. I think the problem may be an issue with the websocket connection to the node-red server from the browser.

[Edit] Ignore this post, it crossed with the missing nodes posts. That is undoubtedly the problem.

Most of those will be installed if you install node-red-dashboard.

I stopped and started node-red. The log (incl nodejs version):

tpi@raspberrypi:~ $ node-red-stop
Stop Node-RED

Use   node-red-start   to start Node-RED again

pi@raspberrypi:~ $ node -v
pi@raspberrypi:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to

Starting as a systemd service.
25 Jul 22:51:21 - [info]
Welcome to Node-RED
25 Jul 22:51:21 - [info] Node-RED version: v3.0.2
25 Jul 22:51:21 - [info] Node.js  version: v16.20.1
25 Jul 22:51:21 - [info] Linux 6.1.21-v7+ arm LE
25 Jul 22:51:24 - [info] Loading palette nodes
25 Jul 22:51:27 - [info] Settings file  : /home/pi/.node-red/settings.js
25 Jul 22:51:27 - [info] Context store  : 'default' [module=memory]
25 Jul 22:51:27 - [info] User directory : /home/pi/.node-red
25 Jul 22:51:27 - [warn] Projects disabled : editorTheme.projects.enabled=false
25 Jul 22:51:27 - [info] Flows file     : /home/pi/.node-red/flows.json
25 Jul 22:51:27 - [info] Server now running at
25 Jul 22:51:27 - [warn] Using unencrypted credentials
25 Jul 22:51:27 - [info] Waiting for missing types to be registered:
25 Jul 22:51:27 - [info]  - ui_tab
25 Jul 22:51:27 - [info]  - ui_base
25 Jul 22:51:27 - [info]  - ui_group
25 Jul 22:51:27 - [info]  - serial-port (provided by npm module node-red-node-se                                                                                                                                                             rialport)
25 Jul 22:51:27 - [info]  - ui_spacer
25 Jul 22:51:27 - [info]  - moment
25 Jul 22:51:27 - [info]  - buienradar
25 Jul 22:51:27 - [info]  - ui_gauge
25 Jul 22:51:27 - [info]  - ui_chart
25 Jul 22:51:27 - [info]  - ui_template
25 Jul 22:51:27 - [info] To install any of these missing modules, run:
25 Jul 22:51:27 - [info]   npm install <module name>
25 Jul 22:51:27 - [info] in the directory:
25 Jul 22:51:27 - [info]   /home/pi/.node-red

Is it perhaps a possibility ( see RaphWetzel post) that i deleted all the imported flows and just import the one showed here?

Regarding the nodes not installed, this warning should have popped up when you deployed a flow as I suggested.
It would have helped to tell us about it! :grinning:

You can fix it via the hamburger menu | Manage Palette.
There is an install tab.
It looks like you need

  • node-red-dashboard
  • node-red-node-serialport
  • node-red-contrib-moment
  • node-red-contrib-buienradar

Or you can delete the flows using those nodes. Also you may have to check for unused Configuration nodes (in the menus) and delete those.


very sorry not telling about it, of course no intention at all. Just ignorance. The good news is that after installing the nodes all buttons working fine again.
Many thanks to all the advisors.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.