[ANNOUNCEMENT] : node-red-contrib-zwave-js V7

Also, when I reinterviewed that node yesterday (I did not do a remove/add just a reinterview) it did reset the name to the device defaults. Is that a sign that the name is only getting stored in the local database and not being pushed to the device at all?

Sorry for the delay.

That's correct.

During an interview, any Node Naming support discovery, will result in the devices reported name being used.

But because the driver thinks it's not supported later, no attempt is made to write any updates to it later.
A bug report will need to be provided (on the zwave-js repo) to get it corrected.

Thanks. I'll get the trouble ticket submitted to the ZWave JS team

Not many devices actually support Node Naming, so it's likely an overlook of some kind.

I am part of the team, just not the driver portion.

I look after the Device Database website (that you seem to know of :smile:)
The NR module and the Microsoft .NET class library.


Finally I upgraded to version 7.
All works perfectly.
Thank's for your support.

1 Like

I got tied up on work yesterday, and jury duty today (and now at least tomorrow morning). Still on my to do list..... Did submit the naming bug today

and jury duty today (and now at least tomorrow morning).

I thought the JD, AH case was over :wink:

The naming bug has been identified, and should be patched in the next driver release.
If this patch stays within the v9 run of the driver (It looks as if it is :crossed_fingers: ), you can do an in place update.

cd ~/.node-red
npm install zwave-js@latest

(and restart of course)

if it appears in v10 which is currently being worked on, it will need to wait my end.
v10 has some changes I need to incorporate, until then the module will only work with the v9 run.

1 Like

Finally got a chance to test.

Steps 1 -3
The sending multiple associations in a message worked to associate all of them to the Group. I was then able to set the dim level and it did get applied to all the nodes identified.

Steps 4-5
When I sent the 2nd group of nodes it overwrote the first group of nodes, so only the 2nd group at the 2nd dim level worked.

Close..... Though shouldn't your current add associations when you add multiple groups nodes together work for this w/o having to add new functionality/UI?.

As far as UI, when I've programmed the Scene controller through HomeSeer it just has a node id and dim level for each one as you add them to the association group.

[EDIT] Though I did only clear the associations on the Group that I programmed not the entire scene controller?

[EDIT] The add associations is being picked up in the UI as well (but just for the one set)

Hi Marcus,
it was to early to be excited. :frowning:
Funny enough, I was still running on 6.5.5.
Today I tried again to update to 7.1.2 (latest) with the same result as last time.
When I started node-red it could not register some types which resulted in the missing Z-Wave JS Controller.
Do you have any idea what could be the problem?
PS: Same problem with npm and palette upgrade

Hi @juntiedt

Presently, I can only assume something environmental is causing an issue.
My first assumption was you're using docker - which has issues with serial port v10.

The next thing to try is to wipe out the module entirely, and do a fresh install.

it is better to PM me to do this, as a few steps are required.

For anyone having the issues that @juntiedt had (or similar) installing V7.x.x
(especially when you have travelled up the versions from 6.x.x)

Removing the package entirely seems to have fixed the issues.

This involves stopping Node RED, removing the package (and all of its components) from package.json, deleting any left over folders, and recreating package-lock.json

This can require steady hands - so caution is advised.
I can only assume some previous update was leaving left overs, and causing issues with V7


ZWave JS 9.4.1 has just been released, and should fix the node naming bug.

cd ~/.node-red
npm install zwave-js@9.4.1

Restart Node RED

Awesome, thanks for the heads up. Just tested and works!!!


Not many devices actually support saving its name internally, so its a rare occasion the driver attempts to do so.