Blank page on mac/webkit

Hi. Tried to run my dashboard on a LG smartTV.. the dashboard works on every machine i try, desktop, smartphone etc. The LG-TV seems to run some webkit based browser so i downloaded Otto-browser to my desktop and tried the dashboard and i get the same error.. I get a blank screen. I run the console to receive this messages :
bild

What is the Otto browser ? doesn't seem to be common/obvious at all ?
What is causing the 404 ? can you expand?
Which model TV ? What level software ? (not something we are likely to have lying around to test but hey you never know)

Depends on the age of the TV and whether you've updated the firmware. I think all of the newer LG TV's use their webOS which is their own version of Linux. webOS switched from WebKit to Chromium back in 2016 I believe.

So you may wish to see if there are updates for your TV. A 7-year-old browser is really quite ancient so not surprising if it doesn't work.

If you can't upgrade the OS on the TV, I'd probably recommend getting an Amazon Firestick or other similar Android-based external dongle.

Otto-browser is a small browser based on webkit.. i downloaded it to test and i get the same problem with that browser as i get on the TV.. It is an LG 60UH615V-zb..
I have no idea why i get 404.. When i go to either the flow page or the ui i get a blank page..

I updated the TV today with the latest available firmware but still the same problem.. yes i newer TV could solve the problem and we are likely to buy some new hardware for using in the factory but it would also be good to be able to run it on our current TV since it is already mounted on the wall..

Google can't find that, only Otter browser which is an Opera clone.

Hopefully your Otto-browser has a network tab in the dev tools? If so, you can use it to find out exactly what has generated the 404.

Unfortunately, TV's are notoriously poor for browsing and updates.

I wonder though if it is the 404 that is causing the issue. Alternatively, is it possible that the TV is on a different network segment?

sorry.. Otter-brower is correct.. i get :
bild


Well unfortunately, that isn't showing what failed to load.

This is how it looks in firefox when everything is loading correct.

I think it is something with the stylesheet that is not working.

i get this error in the debugger of Otter-browser

OK, so in doing some background reading on this, it is clear that Dashboard will not work in browsers that don't support at least ES2015. That is when strict mode changed its settings to allow block-level functions.

So unfortunately, you are out of luck with Dashboard. You would need to switch to a hand-crafted display using http-in/-out and template nodes. uibuilder doesn't support browsers that old either I'm afraid.

1 Like

ah.. ok.. That was sad to hear. well. i guess we need to buy some new TV's then.. perhaps i can try to make 1 custom dashbord for that TV since it is only 1 dashbord i want to show on TV.. Thanks for the help.. good to know what the problem is instead of spending a lot of time trying to fix it..

I personally would advise going for cheap TV's with an external Android dongle. The reason being that TV's can last decades but their "smart" services are unlikely to last anywhere near that long. A dongle is cheap to replace or upgrade.

Yes, that could be a way to go..is there any cheap and easy dongle to use without a lot of extra stuff ?

They all have extra stuff. I've not looked for a while so you would need to do a bit of research. Though the Amazon Firestick often seems to be reasonably priced, reasonably configured and reasonably usable :slight_smile:

or indeed a wireless Pi is fairly small to hide behind a TV.

1 Like

Is there a good Android build for Pi these days? With Rasbian or similar, you are running a full Linux desktop to get a browser. The reason for recommending Android is to avoid that and to get a TV-friendly interface.

And you would also need a case and power supply which a pre-packaged unit would give you.

I have heard not too bad reports of running Lineage on Pi - but...
Android is Linux/java under the covers as well... so I'd stick with one that just works... (and indeed could run Node-RED locally ;-).
Plenty of cheap cases around...

Just as an aside... I was given a couple of Amazon Firesticks for Christmas.
Will the 'cast' node (that I've used with one of my Chromecast sticks) work with a Firestick?

I assume the Firestick uses a different port?
If so, does anyone know what is it?
I use port-8009 with my Chromecast.