Dashboard blank page on old iPad

While still trying to (ab)use my old iPad with iOS 9(!) as a permanent wall display I suddendly stumbled over these mysterious errors which are hard to explain and track down:
The iPad was able to display most of the UI elements. I was in the process to install the canvas-gauges library in my static folder and first test where promising. The gauges displayed fine on this old device.
However suddenly (and I mean really suddenly!) the iPad refuses to display any dashboard content, simply showing a blank page.
Of course I was trying to roll back to the NR state but nothing changed. Something (on server or client side is blocking the dashboard completely..

This maybe more a general javascript, browser issue, not really specific for NR, but maybe someone with more experience on javascript, library loading etc. can give me a hint where to start looking?

  • how can I get a log file of the NR http server (on my Raspberry3). There is nothing in syslog, nothing in lighttpd/access.log

Actually Safari on that iPad can still load some other web pages..

For a long time, iOS Safari was stuck a long way behind the curve in supporting web standards. This meant that it often baulked at things that we took for granted elsewhere. In addition, older versions of iOS sometimes really didn't like the massive bulk that the Angular v1 framework (that Dashboard uses) drags with it. Newer versions don't seem to have the same problems partly because Apple eventually woke up and realised that they needed to support modern web standards and partly because of better hardware.

What you really need is to see the browser console log. I believe there are ways to get hold of that but I'm afraid life is too short for me to keep pampering Apples weirdness. I have a nasty suspicion that you would need an Apple dev environment.

I got an old iPad running 9.3.5 and it is able to see my dashboards. It’s slow but they show up.

What changed? Did you add something to the dashboard?
Why not create a new flow with a minimal dashboard and see if it will show up?

I also use an old iPad mini (iOS 9.3.5) for my dashboard and I also only see a white screen.

In the remote debugging app "Inspect" (https://inspect.dev) I see the following error message.

Additional screenshot from a second try:

Thats exactly what I am asking myself: what changed? I was testing a new gauge vertical slider (from the canvas-gauges library) on the old iPad!! which showed up nicely but suddenly refused to display anything! Something "broke" here and I have no clue.
I am aware of the problems with older devices, angular versions, use in NT etc... I would have never started the effort if a certain UI element would not be displayed at all -> not compatible, ok stop...

I already tried to disable most of my dashboard pages, limit to one simple UI item.. no success.
I will try to use another NR test installation from another machine.

so this web tool works on old iPads? I will give it a try. Unfortunately these error messages are still hard to decode.

I think that the first error is telling you that there are too many errors for the debugger to track?

I think that the error on line 531 (if you are using the current version of Node-RED and Dashboard) is something to do with the dynamic less CSS compiler that is built into Dashboard

After playing around and constantly asking myself "what has changed?" I solved the problem by downgrading node-red-dashboard to version 2.22.0 (just a first guess in picking an older release)

Old iPad shows content again, slow but reliable, user happy :grinning:

FYI the Ipad I tested with accessed a Pi with node-red-dashboard 2.28.2 so the version might not be the issue or might be just part of the issue.

What version of NR and node.js is the iPad accessing? (you can find that in the NR startup log.)

Yes, for such tedious backward-compatibility issues downgrading might not always be the solution.

I am using the latest V2.0.5 for the NR system including all latest updates for 3rd party modules. Except Dashboard of course :wink:
Would be interesting to identify the root cause for the incompatibility in my case. I will take a look at the GitHub pages.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.