I can't see the dashboard on the ipad

I have seen some user with the same problem, and they comment that it is a version problem, I have looked in the palette and it goes to 3.4.0. I think that installing 3.2.0 would be enough, since there was a time when it worked for me. .. how can I install a previous version? can you help me, please??

Try to clear the browser cache first.

I'm currently looking at the dashboard on my iPad. The dashboard is v3.3.1 and NR is v3.1.0-beta2.

Are you using HomeAssistant or a different dashboard than node-red-dashboard?

Which browser are you using on the iPad?

I am not directly using the node red dashboard

It's an old iPad hence the problem

what are you using? With out details, it is hare to know how to help you.
Which iPad are you using?

I am using an ipad 4, safari browser. I have tried different browsers without success...
The dashboard ui of node red, and in version 3.2.0 it works on this machine...

There are multiple dashboards available to use in NR which is why I showed you the exact name of the dashboard I'm using, but you haven't so I don't know what you are using. and when you say 'in version 3.2.0 it works' what does the 3.2.0 refer to? NR? the dashboard node? something else?

And you haven't answered the question about HomeAssistant
and now I'll also ask Are you using Docker?.

If you want people to help you, answer ALL the questions they ask.

No, I don't use home assistant, nor dockers, just node red. The package I'm talking about is node-red-dashboard I currently have version 3.3.1 installed. If I have left any information sorry I am new to this and I do what I can

I have an iPad Mini 2 (A1489) with IOS 12.5.7 and using Firefox in Kiosk mode the NR Dashboard (3.3.1) displays fine. NR ver. 3.0.2. Works with Safari as well.

Not trying to teach you to suck eggs, but are you using <IP Node-RED server>:1880?

In your original post you said:

What were you looking at? The latest version of node-red-dashboard is v3.3.1.

What version of Node-RED are you using? (you can find this at the bottom of the top-right hamburger menu

when you said:

what were you referring too? Node-RED? the dashboard node? Something else?

[EDIT] Ahhh, I just looked on GitHub and see that node-red-dashboard has been updated to v3.4.0, but it is not showing in the 'Manage palette' - I'll contact the developer about that.

[UPDATE] it is now showing in the Manage palette

But - yes - if the ipad is old and safari is old then indeed the version of javascript supported may not be sufficient, and may no longer be workable.

If you want to downgrade the dashboard here is what you have to do

  1. open a terminal session on the device running node-red
  2. stop node-red
  3. change to the .node-red folder
    cd .node-red
  4. install a previous version:
    npm i node-red-dashboard@3.2.0
  5. restart node-red

jajjaajjajaja don't worry, what versions do you have? Why doesn't it open for me?

jajjaajjajaja don't worry - Sorry, don't understand, do you need help or not?

what versions do you have? I don't understand what you are asking, see my post, I have tried to show with the versions of my configuration that an old iPad will work with Node-RED.

This is more about what you have than what I have, my setup works, and has done for several years... All I can say is that I am up to date with all stable versions of software.

For completeness (from my end) here is my Node-RED configuration..

12 Mar 15:32:50 - [info]
Welcome to Node-RED
12 Mar 15:32:50 - [info] Node-RED version: v3.0.2
12 Mar 15:32:50 - [info] Node.js  version: v16.19.0
12 Mar 15:32:50 - [info] Linux 5.10.103-v7l+ arm LE
12 Mar 15:32:51 - [info] Loading palette nodes
12 Mar 15:32:56 - [info] Dashboard version 3.4.0 started at /ui

What version of IOS are you running?

You say...

Where have you seen this?

As @zenofmud has described, it is possible to revert to earlier versions. Did you do something/update any nodes just before this problem occurred, or has the iPad ever been used with Node-RED before?

As @dceejay says, it is possible that your version of Javascript is too old and won't work with the current version of node-red-dashboard.

Lots of questions, I know, but at the end of the day, mine works, so I have no problem - I can't fix mine, it is not broken. Yours on the other hand appears to be not working. We are trying to help you, but, you have to help us to help you.

@Hagory85 If you want us to help you, you need to answer the questions asked of you. We cannot make guesses as to what your exact configuration is.

Welcome to Node-RED


12 Mar 16:04:25 - [info] Node-RED version: v3.0.2

12 Mar 16:04:25 - [info] Node.js version: v16.17.0

12 Mar 16:04:25 - [info] Darwin 19.6.0 x64 LE

12 Mar 16:04:26 - [info] Loading palette nodes

12 Mar 16:04:28 - [info] Dashboard version 3.3.1 started at /ui

...and the IOS version on your iPad 4 is?

Don't use Apple other than for convenience and so not experienced with their Software versions, but after some research, your iPad IOS may well be too old, but with no version available from you, just guessing.

Have your tried loading Firefox onto it? Using Firefox may, or may not help, But I think I read somewhere that Firefox (and any other Browser) still has to be tied in to some sort of Apple Safari layer within the OS.

Yes, it's a software issue for the ipad, since I have an ipad pro and it works perfectly there

Sorry, what do you mean in point 3... I use Mac and it's a little hard for me to find the equivalences

Open a terminal window and enter cd .node-red
that will put you in the .node-red folder. Here is an example of what I see:

Last login: Fri Mar 17 04:23:10 on ttys002
paul@PaulsM1 ~ % cd .node-red
paul@PaulsM1 .node-red % ls -l 
total 2816
-rw-r--r--@   1 paul  staff   252974 Feb  9 08:20 castleton-duck-in.jpg
drwxr-xr-x    8 paul  staff      256 Mar 15 05:22 context
drwxr-xr-x    2 paul  staff       64 Jan 26 04:43 cronplusdata
drwxr-xr-x    2 paul  staff       64 Feb 17 05:44 dist-plugins
-rw-r--r--    1 paul  staff    23705 Jan  5 13:05 flows.json
-rw-r--r--    1 paul  staff       79 Jan  5 05:27 flows_cred.json
drwxr-xr-x    4 paul  staff      128 Feb 20 04:03 hourglass
-rwxr--r--@   1 paul  staff    10392 Feb 22 04:04 hss_yolo_analyzer.py
drwxr-xr-x    3 paul  staff       96 Dec 30 17:49 lib
drwxr-xr-x    3 paul  staff       96 Feb 14 17:08 mcu-plugin-cache
drwxr-xr-x  816 paul  staff    26112 Mar 17 05:08 node_modules.  
-rw-r--r--    1 paul  staff  1090225 Mar 17 05:08 package-lock.json
-rw-r--r--    1 paul  staff     2794 Mar 17 05:08 package.json
drwxr-xr-x  183 paul  staff     5856 Feb 27 05:31 projects
drwxr-xr-x    2 paul  staff       64 Feb 11 07:15 rpinotes
-rw-r--r--@   1 paul  staff    23209 Feb 26 09:50 settings.js
-rw-r--r--@   1 paul  staff    22614 Dec 30 17:49 settings.js-old.js

Thank you very much, it is solved