Can't Connect to local IP

Basically when i start node red on ubuntu 20.04(virtual machine) it starts and to use it i need to pick my windows local ip address to enter in node red. But it doesnt work. The page doesnt load.

It looks like you CTRL+C exited node-red - hence you cannot access the editor.

Try running node-red once more - but leave it running in the terminal - then try accessing the editor.

Once you have that working (assuming you installed node-red using the official script) you can start it as a service by entering node-red-start

I just CTRL+C to show my local ip address. I dont know to fix this.

I see you are running in a VM. Have you setup the networking to permit access? Try pinging that IP. Look at the VM firewall / IPTABLES

I can ping that ip

Is that pinging from the host or inside the VM?

This is VM pinging ip

Do you know how to fix this?

Im using Oracle VM for my Node-red test system also .. im running Win 11 and not Ubuntu but the settings should be the same.

If i remember correctly (its been months since i set it up) you have to go in the settings of the VM and change the Network settings to Bridged Adapter
.. so the VM can get a seperate IP from that of the host system.

also can you confirm what the IP of the host is
and what IP of the VM after the changes ?

1 Like

I already Have it like that, i have internet connect on the VM , i can ping
my ipv4 is

I see .. and what about if you are running a firewall as @Steve-Mcl asked ?
sudo ufw status

Status inactive

I just noticed the Bridged Adapter is the WIFI adapter ?


Do you also have wired connected on the host ?

I only have wifi on my laptop.
my router ip: (that is the host ip?)

i have a desktop with wired connection

ok .. just checking in case you accidentally selected the WIFI adapter as a bridged Adapter but the wired adapter was the one in use .. now that i think of it, since you have internet on the VM, it cant be this.

No. the system that is running Oracle .. is it Windows ? its IP.

its WIndows 10

image ???
The same IP as the VM ?
something is wrong there

have you restarted the VM after setting up the Bridged mode ?
Have you setup a static ip on the VM by any chance ?
or are your systems (host and VM) setup to get IPs from the routers DHCP ?

No i didnt setup a static ip

when i put: (ip a ) on the VM
Thats what appears