Can't delete nodes/flows

I started with Node -RED on a Pi3, up to now everything worked just fine. Started now to install Node-RED on a Pi4 in a Docker-container. First everything worked like expected, but now I have a strange problem: at a certain point the 'deploy'- button does nothing, and some of the nodes have still a blue dot. No error message, nothing.
When I reload the page, my changes are gone, and an old state of the nodes is present again. Same with a complete flow-sheet. Deleted the page, reload - everything there again.

I have to say, that I imported some of the flows from somewhere. Deleted also the config nodes- after reload everything appears again.

How can I get rid of this stuff?
Cheers, Georg

Try creating a file on the SD card and then power off the pi and power it up again and check to see if the file is still there. If not, extract the card, and flick it across the room, Frisby style, into the bin. Then start again with a new card.

...this worked. File is still there.

It does not matter if I get rid of all the flows that I created so far and start from scratch.
But how?

Just delete your .node-red folder.
Before that, check the permissions on that folder and on the files in it. I suspect node red has not got permission to overwrite the flows file.

Thanks for the input.

hm, is it enough to rename the folder in order to get back easily?

I (think I) do not have the '.node-red'- folder, because I use a docker container. I guess my flows are stored in the 'volume' for node red (see attached, the name there is 'nodered' and under 'data' I have this files. What do you think?

I personally don't think, that this is a permission problem due to the fact, that sometimes I can save some nodes, but not always and these come back after reload (but also the deleted ones...)

Don't know much about Docker I am afraid.
If you are using Docker can't you just redeploy the container, or whatever you do with Docker to get back to a fresh image?
It is interesting that you have two flows files, flows.json and myflows.json. I suspect you may be using different flow files at different times, or something, and that is why it keeps reverting the flows. Or perhaps you are re-starting the container and it goes back to the base image, I don't know enough about Docker to know if I am talking sense or not.
Try watching the dates on those to see what happens when you deploy. If you look at the node-red log ( I don't know how to see that in Docker, but presumably you do) it will tell you what flows file it is using. If you rename all the contents the data folder (or move them to a subfolder or similar) and restart node-red it should start with an empty flows file (which won't exist until you Deploy it the first time).

1 Like

Thanks Colin for all your help.

Sorry about the confusion about the 'myflows.json', this was a leftover from my test yesterday ('is it possible to write a new file ?')

Will try now your tips, let's see...

Cheers, Georg

Hey, perfect!
Stopped the container (ok, I guess this is one advantage of Docker - very simple), and renamed the 'data' folder. Started the container up and boom: empty sheet. Deployed a simple flow and a new 'data'-folder with content was written !

perfect, thanks a lot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.