Can't resize or reposition widgets in layout grid view?

A couple of times now, I have navigated to the layout view for a given dashboard tab, and I can't move or resize the widget bounding rectangle. The cursor changes to the 4 pointed arrow icon, but clicking on the widget rectangle, it will not move. Clicking on the lock icon, will lock or unlock, but resize of the rectangle will not activate. Is this a known bug? It is hard to provide evidence of this, because the cursor and lock icons change mode as expected but the expected behavior never engages or invoked. Stopping and starting node red does not seem to fix this issue. exporting and reimporting the problem flow does not seem to fix the issue. So far, once it happens it stays stuck, until at some point becomes unstuck again. But I have not yet seen a consistent way to force things to become unstuck.

Full reboot seems to have resolved the issue for now. This feels like some type of resource constraint or limit maybe? Given Pi had been up for quite a long time. Also tried 3 different browsers, issue does not seem to be browser specific.

There is an padlock icon associated with the groups.

I think that has some effect on what you can and can't do with the group, and it is (to some) counter-intuitive to what it is doing/meaning.

eg: Locked means not locked and unlocked means locked.
I can't be specific as I haven't really used it but I remember reading that.

The lock is locking and unlocking as expected. It is the bounds rectangle placement that is failing. If the lock is closed, you should be able to move the bounding rectangle, as a floating object, such that automatic spacers are generated. When this issue happens, I cannot move the bounding rectangle at all, so no spacers are ever generated. So this not a case of the lock blocking or not blocking movement. The lock controls the bound rectangle behavior, not the bounding rectangle placement in relation to other widget bounding rectangles when the lock is closed. This is not normal behavior, and it usually happens to just one tab initially, others tend to work as expected at least initially. So far I have seen this happened twice on two different instances of NR. The common theme is that both the NR instances are running on smaller/older Pi devices. Suggests this might be some type of resource limit issue. Rebooting the Pi tends to clear the issue, but restating NR does not seem to clear the issue. Might even be a memory leak of some type..

As I said: I haven't really used that much, so really I can't be of much help.

I just wanted to mention the trap with the icon of the padlock. But it would seem you are already aware of that and have it worked out on that side of things.

Yeah, that would make sense, but given how this happens, I am not sure this is a bug or a feature but something else impacting the feature.

Unless a lot of others have seen this... it really does feel like some type of resource issue or such. Why would a reboot of the OS clear the issue?