Dashboard Update Failed on windows


#1

Hi, I want to update my Node-RED dashboard to the newest version 2.13.2. Node-RED is running on a windows 10 laptop. If I cklick update to 2.13.2 in the manage palette, the following error appears:
image

the log file:

Microsoft Windows [Version 10.0.17134.523]
(c) 2018 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\tobi>node-red start
11 Feb 15:12:28 - [info]

Welcome to Node-RED

11 Feb 15:12:28 - [info] Node-RED version: v0.19.4
11 Feb 15:12:28 - [info] Node.js version: v10.8.0
11 Feb 15:12:28 - [info] Windows_NT 10.0.17134 x64 LE
11 Feb 15:12:29 - [info] Loading palette nodes
11 Feb 15:12:31 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
11 Feb 15:12:31 - [info] Dashboard version 2.9.6 started at /ui
11 Feb 15:12:31 - [warn] ------------------------------------------------------
11 Feb 15:12:31 - [warn] [node-red/tail] Not currently supported on Windows.
11 Feb 15:12:31 - [warn] ------------------------------------------------------
11 Feb 15:12:31 - [info] Settings file : \Users\tobi.node-red\settings.js
11 Feb 15:12:31 - [info] Context store : 'default' [module=memory]
11 Feb 15:12:31 - [info] User directory : \Users\tobi.node-red
11 Feb 15:12:31 - [warn] Projects disabled : editorTheme.projects.enabled=false
11 Feb 15:12:31 - [info] Flows file : \Users\tobi.node-red\start
11 Feb 15:12:31 - [info] Server now running at http://127.0.0.1:1880/
11 Feb 15:12:31 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

11 Feb 15:12:31 - [info] Waiting for missing types to be registered:
11 Feb 15:12:31 - [info] - ui_spacer

Does anyone know the reason?


#2

Hi @Tobi

a couple comments:

You are starting Node-RED with the command node-red start. That is telling Node-RED that you want it to store your flows in a file called start. The word start doesn't have any special meaning as an argument to the node-red command. But as you have already used that command and have flows saved in the file called start, you better continue running it like that so you don't lose them.

The reason for the 'not installed locally' error will be related to how you originally installed the Node-RED Dashboard module. You may have installed it as a global module (using npm install -g node-red-dashboard - take note of the -g flag). Node-RED cannot upgrade modules you have globally installed.

To fix it, you can install it manually in the local node-red directory. Open a command prompt in the directory \Users\tobi.node-red\ and run npm install node-red-dashboard and then restart Node-RED. That should do it.


#3

thanks this worked :smiley: