Debug status not working - I think

I am not understanding why this isn't working.

Ok, originally the message was in msg.time - and I realised it has to be msg.payload.

So with that, the status still isn't working.

Node-red version?



RasPi (Buster)


I put the test inject node and the test gets displayed.


On the right (same setup) the date is displayed.


Pic to share:

I suspect a temporary browser issue. Caching or something. Restart node-red, clear the browser cache and refresh the page.

1 Like


Didn't think of that. (Brain failure)

Flushed cache tried again, no change.


Still not working.

(I'll have to try a different browser shortly)

But, just to see if I can see anything else....

The BLUE lines are helping you follow the wires.

See the RED line. TEST node.

You are seeing the ON message.
But even on that debug node, the msg.payload is not being displayed.

I'll try another browser and share the results.


Ok, I was a bit slow with the screen shot.
The time out node works.
You can see the time (green lines)
They match. Even check the top of the screen's time.

But time in is not working.
I did notice the circle in the TEST is empty where as the others are full.
Yes, the time out node has test in it.
But if you look a the node above it, the TEST text is blank and the circle is empty.

I pressed the inject node and got the test text to appear.

It isn't critical, but it does seem weird.
Though I am using NR 3.0.2 and not the latest.

This is more to share what I am seeing is anyone else is using this version and seeing weird things happening.