Debugging and Notification issues

Hi chaps,

I have Node Red running in HA, it installed version 1.3.5 in the add-on 9.1.3. I've been using NR for a few years and love it. Since this update my debugging stopped working as well as the notifications under the nodes that tells you what is going on. I checked and I have the option enabled:


I am not sure if there is an easy way to downgrade or if anyone has any ideas on how I can get debug to work again?

Many thanks

Hi @alamapstieks

Whilst I can't claim any knowledge of how NR is embedded in HA, the symptoms you describe indicate an issue with the websocket connection from the editor back to the NR runtime.

We've not had any reports of issues, in HA or otherwise.

Can you try a different browser just to rule out anything on that side?

Thanks for that, to my knowledge you just need the node-red-contrib-home-assistant-websocket. I am on the latest.

I just tried it in both Chrome and Firefox... no joy. Same issue with no debugging or status.


Actually I am not sure it could be a websocket issue as Node Red works, all the scripts run just fine. The only issue is that they don't provide a status any more, nor does the debugging function run

The debug messages and status updates get to the editor via a websocket connection. This has nothing to do with the ha websocket nodes you've mentioned - it is entirely internal to how the editor/runtime communicate with each other.

The fact you're not getting either debug or status tells us something is wrong with that websocket connection.

Have you tried a different browser? Checked the browser console for any errors?

Yes, no luck in getting errors or getting it to work in other browsers. For now I will try to downgrade and see if I can get it working at least for now.

Thanks again, I really appreciate you trying to help!

I downgraded to 1.3.3 and it is working again :smiley:

I guess I will just wait a few months before I risk upgrading...

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.