Docker - Issue after restore volume


After losing the volume of a dockerized installation of node-red, I recovered succesfully everithing using the version control option available on nodered since the latest version (GIT CLONE).

Everything seemed ok until I attempted to add a something to my palette.
After the install, all seems ok, but at the first restart of the container I get an error from the web console:

Flows stopped due to missing node types.

  • telegram bot
  • smb config
  • rmdevice2
    with a list of ALL the node types used on my flows, but not the new one just added.
    Of course a wrong message: everiyhing worked fine, restarts included, until the change to the palette.

Where I can start looking for the cause of this anomaly ?
May be some missing file or wrong permission?

I recreate the case with the latest versione (2.2.2).

Thanks !


I think to have found a fix for the issue.

The procedure may be a little strange but it worked.
1 - restored the docker volume from the last back-up width the container stopped and then start it
2 - gone to the Project settings -> Dependencies menu
3 - add all the dependencies to the project (greyed with the ubbon "add to project" visible) must be all the depencies actually
4 - edit the dependencies and copy all the "node-red ..." list of modules on a separate text editor
5 - add another module on the palette
6 - restart nodered container: get the error of the missing nodes
7 - run a shell on the container (docker exec -it NODEREDCONTAINERNAME)
8 - on the shell run "npm install" command for all the modules saved at the point 4
9 - restart nodered container
10 - no error of missing node types: back on business!

I think the cause of the error could be that I did not add the dependencies to the project before losing the docker volume. This prevented the version control on GIT to save correctly all the dependencies.

But I'm just pretending to know ....actually I'm not so knowledgeable into NPM and NODERED inner workings.

Hope this helps!


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.