Enable projects on Windows10 with v2.0.6?

Taking a detour helping setup Windows 10 for a friend. Got node-red v2.0.6 running apparently correctly, but I don't see the "Projects" selection in the hamburger menu.

I edited the settings file
editorTheme: {
projects: {
// enabled: false,
enabled: true,

But when I restart node-red, I don't get the Projects menu selection.

This is my first use of v.2

I notice there is an exec node in the pallet, has this been make to work on Windows 10? The "info" still uses "Unix" descriptions for how to use it.

The node-red log will tell you why projects hasn't been enabled.

It is usually because you don't have the git command-line tool installed on the Windows machine.

It has, as far as I know, always worked on Windows. Have you tried it?

Thanks, no I haven't tried exec on Windows, but if it works it'll make the start/stop of my PythonAI work the same as it does on Linux. I'm not a Windows guy, having given up on it when Windows 8 came out.

I'll install git for windows. The projects feature is worth the effort now that I've actually used it a bit on my Pi4B system.

It does work and I'm currently using it on W10.

THe exec node works just fine.

I just installed git for windows 10

git --version shows 2.33.1.windows.1

But still no projects in the menu. Do I need to something to git post install for this to work?

What does Node-RED log when it starts regarding projects?

If it is still saying something like 'git command not found' then you need to make sure the newly installed git command is on the path.

If you try from a new command or PowerShell prompt, can you type git --version? In other words, is the path correct?

And how are you starting Node-RED? Have you tried from a new command or PowerShell prompt?

My git version is git version 2.33.0.windows.2 but I've used node-red with previous versions quite happily too.

Yes the path is correct, git --version command gives 2.33.1.windows.1 in powershell and command prompt. Scripts seem to be disabled on this system when I tried starting node-red from powershell.

Its working now, seems I may have forgotten to refresh the browser window after enabling projects.