Error Cannot Get /ui when launching the Dashboard on my PC

First off I am very new at this. So please be kind. I had Node Red running on a Raspberry Pi and had a isssue so I did a clean install of the PI and Node Red. After that when I tried to launch the Node Red dashboard from my home PC like before I get the error Cannot GET /ui. I can get on XXX.XXX.XXX.XXX:1880 site.
I have spent hours searching for help online but nothing has helped.

I am using version 2.2.0 of Node-Red

Are you just using /ui or 192.169.1.nn:1880/ui? (Where 192.168.1.nn is the IP address of NR

Also did you install the dashboard?

I am using

I used this link for the installer bash <(curl -sL

Have you installed the node-red-dashboard - node-red-dashboard (node) - Node-RED
and added some of the dashboard nodes to a flow?
If not, go to the palette, and you'll find it in the Install tab.


This is a screenshot of what I have. If I need to install the Node Red dashboard I do not know how to do that.

I did say...

Ok I did find out how to install the Node Red dashboard and successfully did that. It is working except when I a node tries to connect here is a screenshot

Paul when I went there nothing was there to choose from. Now there is. Do I need Mosquitto MQTT to make the node to connect.

I did say...

Are you still trying to get the dashboard working, or are you now trying to use mqtt? If you want to use mqtt then you need a broker such as mosquito.

I recommend watching this playlist: Node-RED Essentials. The videos are done by the developers of node-red. They're nice & short and to the point. You will understand a whole lot more in about 1 hour. A small investment for a lot of gain.

Paul why do the payload settings keep reverting back to True and false when I try to set them to 1 and 0

As @Colin has said, you really need to spend a little time watching the Node-RED Essentials playlist to get a better understanding how node-RED works.
After that, if you have a problem, please start a new topic, and fully describe what the problem is, and what you have tried to solve it.

I did get the dashboard working. I just reinstalled it on the PI.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.