Flexdash, Dark theme, default

Continuing the discussion from :rocket: [FlexDash] alpha release - a dashboard for Node-RED:

I am unable to get the dark theme as default with the proposed solution in this link, please guide me.

1 Like

What have you tried?

i have few batch files on desktop to open few node-red dashboard and Flexdash as well.
i just added ?theme=dark at the end as below as said in your post that i have linked in my op. it does opens the dashboard, but always in default light mode.

1 Like

Hmmm, for me this works on Linux:

> chromium 'https://core.voneicken.com/wcc/?theme=dark' --kiosk

I assume you also need some form of quotes on Windows due to the '?'...

quotes gave me syntax error.

I tried --force-dark-mode in the command line, it turned the browser to dark mode, but FlexDash is still in light mode.


This did it !

Edit: Er. Jumped too quickly, it does turn the page dark, but everything is dark even the dark letters in light mode are still dark. i cant read them.
this dark is not same as when i set dark from flexdash

back to square one...

quotes gave me syntax error.

single or double ?

single gave syntax error, double did not change theme color, but opened light mode

single gave syntax error

You only enclosed the address in quotes ?

Google says the format is:

start "" chrome.exe --kiosk ""

I don't use windows, can't test

this gave me below error

this opened the dashboard but in light mode

this also opens the dashboard but in light mode again.

And what address do you see in the address bar ?

it shows theme= dark in the beginning , but then when dashboard is loaded it shows #1 at the end


Whatever does that sign-in thing probably strips the query string...

1 Like

I removed the dashboard authorization in settings.js and still it is the same issue

it briefly displays (
and then changes to #1

even i entered this directly in browser it is still same


Try The #1 is for tab #1.
I don't know how to reproduce it or why it would happen. Chromium doesn't do that for me, I can dig out my windows laptop tomorrow if no-one else has an idea.

Nope :expressionless:

Try this -

(Note the added backslash after 'flexdash')

@tve you proposed a solution here - 🚀 [FlexDash] alpha release - a dashboard for Node-RED - #188 by Paul-Reed


It works.

1 Like

Argh, I lost that issue :poop:. Thanks for remembering!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.