Flow gone, or not visible

I worked the whole day on a flow, it was 99% finished and now it's gone. :crazy_face:
The tab in the editor where it was on is gone, the other tabs are still there.
Clicking on search flow and type in one of node names used will show the node, but clicking on it will not bring me to the flow.
Looking in the flowxxxxx.json with a text editor you can "see" that there is still something, functions etc that I made are there.
Tried to restore the .flowxxxx.json.backup file, but there's also the missing tab not available.

Anybody a hint/tip to get the tab with my flow back?

Have you got 2 flows files at different locations?
If you stop/start node-RED and look at the log, it will show you the location of the flows file that is being loaded.
Is the one that you mentioned above at the same location?

Yep, the file where we are talking about is the one the got loaded according the log.

Ps, flowxxxxx.json was not the real name, flows_Desktop-Win10-64B.json is.

Do you have subflows ?

Yep, I have 3 subflows (but not used in the missing tab)

look in there.

No, missing flow is not in the subflows.

No additional "unused" subflow on the left ?

No, no "unused" subflows.

Meanwhile I got the missing tab back.
Started NR with a new flow Node-red Testflow
Copied everything from the flows_Desktop-Win10-64B.json file with a text editor.
In the new Testflow Import -> Clipboard.

Missing tab is now returned as Tab1.

I happy now again, thanks for the help.

Please note that by default the flows use the hostname of the computer. If for whatever reason the hostname of the flow changes, it will create a new flow with the new hostname by default. This can be "prevented" by starting node-red with the name of the flow. See the command-line help for the full command:

afelix@Hewlett:~/.node-red$ node-red --help
Node-RED v0.20.7
Usage: node-red [-v] [-?] [--settings settings.js] [--userDir DIR]
                [--port PORT] [--title TITLE] [--safe] [flows.json]

  -p, --port     PORT  port to listen on
  -s, --settings FILE  use specified settings file
      --title    TITLE process window title
  -u, --userDir  DIR   use specified user directory
  -v, --verbose        enable verbose output
      --safe           enable safe mode
  -?, --help           show this help

Documentation can be found at http://nodered.org