Gauge node (compass) in Dashboard v2.19

I have just imported my flow into a new installation of node-RED.
The original dashboard version is v2.17.1 and the the gauge node looks like this -


The new installation is using Dashboard version 2.19 and looks like (using the same flow) -


Apart from the difference in screen resolution for the two systems, note that v2.19 doesn't scale to the 3x3 container.

Must be another breaking change in the justgage library. Maybe @robertsLando has an idea ?

I tried some css manipulatons at dashboard side. Didn't found any easy or straightforward fix to satisfy all layouts.

1 Like

Try to check the option:



Where do i have to check it?

this is the same issue Button Label location

I've pushed a change to the master branch for people to try.

Running from within .node-red I get -

[opc@digitalnut .node-red]$ npm install node-red/node-red-dashboard
npm ERR! code ENOENT
npm ERR! syscall spawn git
npm ERR! path git
npm ERR! errno ENOENT
npm ERR! enoent Error while executing:
npm ERR! enoent undefined ls-remote -h -t ssh://
npm ERR! enoent
npm ERR! enoent
npm ERR! enoent spawn git ENOENT
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/opc/.npm/_logs/2019-11-29T09_23_13_469Z-debug.log

node v10.17.0

@Paul-Reed make sure you have git imstalled on your system, npm tries to execute it but fails to find the binary.

1 Like

well it is there - maybe try https instead ?

npm i

Meanwhile, I'm getting closer. :slight_smile:
The liquidfill stuff takes a bit more than just css. Working on it.

Well this is as on master currently

With what browser?

Chrome and Firefox,

Safari like this - so different but not bad

Seems we reached to near similar results. Time for me to do some other fancy stuff. By having no safari situation at home, can't do much more. :slight_smile:

Sorted! I needed to open Port 443. Now all working thanks.

29 Nov 20:03:11 - [info] Dashboard version 2.19.1-beta started at /ui

Tried clearing cache, incognito mode & three different browsers, and the gauge (compass) still looks the same on each.


Which browser ?

Same result with;
Chrome - Version 78.0.3904.108 (Official Build) (64-bit) (& Incognito)
Microsoft Edge - 44.18362.449.0 (& Inprivate Window)
Firefox 70.0.1 - (64-bit) (& Private Window)
Android Chrome - 78.0.3904.108

Welcome to Node-RED
30 Nov 08:59:13 - [info] Node-RED version: v1.0.2
30 Nov 08:59:13 - [info] Node.js  version: v10.17.0
30 Nov 08:59:13 - [info] Linux 4.14.35-1902.5.2.2.el7uek.x86_64 x64 LE
30 Nov 08:59:14 - [info] Loading palette nodes
30 Nov 08:59:18 - [info] Dashboard version 2.19.1-beta started at /ui

EDIT - Just updated node-RED to v1.0.3 and still the same.

Sorry. Should have asked what dimensions it is

It's been that size for years and has always displayed correctly.

Angular theme maybe?