Gauge node (compass) in Dashboard v2.19

Same result with;
Chrome - Version 78.0.3904.108 (Official Build) (64-bit) (& Incognito)
Microsoft Edge - 44.18362.449.0 (& Inprivate Window)
Firefox 70.0.1 - (64-bit) (& Private Window)
Android Chrome - 78.0.3904.108

Welcome to Node-RED
===================
30 Nov 08:59:13 - [info] Node-RED version: v1.0.2
30 Nov 08:59:13 - [info] Node.js  version: v10.17.0
30 Nov 08:59:13 - [info] Linux 4.14.35-1902.5.2.2.el7uek.x86_64 x64 LE
30 Nov 08:59:14 - [info] Loading palette nodes
30 Nov 08:59:18 - [info] Dashboard version 2.19.1-beta started at /ui

EDIT - Just updated node-RED to v1.0.3 and still the same.

Sorry. Should have asked what dimensions it is

It's been that size for years and has always displayed correctly.

Angular theme maybe?

Not using an angular theme.

Do you use any custom styling? I see the font is also smaller than default.
And how the site sizes are configured
image

Just checked desktop pc (chrome) vs smartphone (android-chrome).

Desktop is fine, android is cut off at the bottom. Something with resolution maybe...

If I set the height +1 (of the width) on the android then the whole gauge is visible.

No other styling, and node-RED is set as per below, and I've used those sizes so it perfectly fits my phone screen.

If you do some searching, you will find a way to run a Mac VM under Linux if you have a suitable laptop or desktop with Linux on it. I think I saw a VM for Windows as well somewhere.

Yeah, I know. But lazy enough.

Haha, no blame there. I've just had to get my 3rd computer from work - I have my main dev PC, a managed laptop (so I can see what the punters have to put up with) and a new Macbook Pro because we are looking after another organisation that is trying to decide whether to use Macs or Chromebooks. Thankfully I don't need to carry all of them around all the time :crazy_face:

1 Like

more tweaking pushed to master for you to try.

2 Likes

I guess that everyone that download and install the dashboard new must have this problem. We are using node-red for remote control of our equipment, and we have several applications where we use the compass gauge to show temperatures. What has changed in 2.19 that causes this problem and is it by any chance possible to install the old version 2.17 again?

You can always install any version of a package. But you have to do it from the command line. Go to your userDir folder and do something like npm install node-red-dashboard@2.17

Thanks Dave, perfect!

wind

Thanks TI, but I am getting all error when trying to do this and it does install the package it seems, but the dashboards nodes does not show up in node-red after restart / reboot.

What can I do more to finish the installation of the package.

pi@nilanconnect:~ $ npm install node-red-dashboard@2.17
npm WARN saveError ENOENT: no such file or directory, open '/home/pi/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/home/pi/package.json'
npm WARN pi No description
npm WARN pi No repository field.
npm WARN pi No README data
npm WARN pi No license field.

  • node-red-dashboard@2.17.1
    updated 1 package and audited 425 packages in 3.965s
    found 0 vulnerabilities

Did you run the command $ npm install node-red-dashboard@2.17 from within the folder .node-red?

I executed the command from the pi user folder. i will try again from .node-red

Before you do, I would run npm remove node-red-dashboard@2.17 from the pi user folder.
Then install it again from within .node-red & restart.

Success - Thanks Paul