GPIOs not working

Good evening everyone,

I have a problem with the GPIO control via Node-RED. Who could help me please?

Hardware: Raspberry Pi zero WH

Software: "Raspberry Pi OS with desktop and recommended software" (kernel version 5.10, based on Debian version 11 (bullseye)); Node-RED version 1.2.9 (Node-RED version included in Raspi OS distribution)

Problem: I would like to use the node "RPi GPIO out" to control a relais. The relais is correctly connected, which I know, since I am able to control it via python command. However, when I try to switch it using an inject node or a dashboard switch, it will not work. The flow should be OK IMHO but I will upload it to this post just in case. :point_left: I am not allowed to upload it, since I am a new user in this forum.

The "RPi GPIO out" node has a grey square below and shows "N/A: 1" or "N/A: 0" depending on my last command. I think, the "N/A" should not be there and the square should not be grey.

From what I read in this forum so far regarding similar topics, there could be some problem with Rpi.GPIO. Therefore I tried installing python3-rpi.gpio, which however was already the latest version (and I am not sure, whether it affects Node-RED to be honest). Also, I tried installing an older version of the NR-gpio: "npm install node-red-node-pi-gpio@1.0.9" and restarted the Pi. It didn't help either.

Thanks for reading so far :slight_smile:


First off I would backup your flow (export it and save it somewhere) then I would update your version of Node-RED by using the instructions here: Running on Raspberry Pi : Node-RED

Your on an old version, so see if that helps.

It works :smiley:

I thought, that with the new Pi OS version a new node-red version would be included - this was obliously not the case.

Thank you for your help zenofmud :clap:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.