Rpi-gpio out node not performing

For controlling an LED with Node-RED I set up my flow according to the instructions in section 2.5.
However, the box blow the rpi-gpio out node indicates "not available".
If I klick the injection nodes nothing happens.

Is it possible for you to share your Node-RED flow (so people can help)?
Also can you indicate how you have wired the LED and resistor.
It would also help if you indicated the version of Node-RED, node.js, the type of RPi and OS you are using.

Section 2.5 of what? Can you share a link?

Also what hardware are you running on and what OS?

I'm using a RPi 4 B with Debian GNU/Linux 11 (bullseye)

and working the tutorial "SMART HOME
Raspberry Pi, ESP32, Esp8266, Node-RED, Influxdb, MQTT"
by Rui Santos & Sara Santos of Random Nerd Tutorial.

Thanks for your support.

Since I don't have access to that book it is difficult to comment on the contents. Did you install node red using the technique in the node red docs?

Which version of node-red are you using (It is at the bottom of the dropdown menu in the editor) and which version of nodejs? The command
node -v
will tell you that.

How is your GPIO out node configured?

What version of the OS do you have? Run this to find out:

grep PRETTY_NAME /etc/os-release

I used the Node-RED installation instruction in the mentioned tutorial:
bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

but not the instructions in node red docs.

Version v3.1.3

I'd rather reload Node-RED for I prefer english as language.

The photo above seems to show your LED connected to GPIO 18 not GPIO 16.

But I think there are issues with the GPIO nodes and RPiOS Bookworm. What does grep PRETTY_NAME /etc/os-release show you?

I think it picks the language up from the OS, but not certain of that.

Also you have not told us what version of nodejs you are using.
node -v

There is an option in hamburger menu | settings for the language. I think you have to restart node-red for it to take effect.

sorry, the node version used is v18.19.0

I'm not using debian bookworm (no PiCamara module included
any more) but bullseye.

I tried both GPIO's on thwe RPI and klicked the corresponding GPIO in the rpi-gpio out node

What does it say under the node when you switch to English?

In fact the image you showed shows pin 16, gpio 23.

now, after switching to the english language and reloading
nodered myflow works, almost:

on the editor I get the correct indications true or false on klicking
the inject nodes.

However, my LED does not respond althoug raspi-gpio get 18 shows level 1 or 0 according to the klicked inject node but only after I sat GPIO 18 to op or output respectively.

Also there is no voltage (3.5V) on GPIO 18 on klicking the ON injection node. But this probabli a RPi problem and has nothing to do with nodered.

Just a silly thought...
Is the LED inserted the correct way wrong on the breadboard?
You could try reversing it through 180 degrees.

Check the LED works by connecting it to 3.3V and GND.
Use a resistor of course!

well no, as I mentioned there is also no voltage (high) on GPIO 18

Show us how you have now configured the node and what pin you are looking at.

of course I cecked my wiring before setting up the flow. The LED works fine.

Finally, after not only setting GPIO as output but also driving it low

raspi-gpio set 18 dl op

it works !!

It would probably worthwile to mention it in tutorials etc.

Thanks all for your support