How to connect to cloud hiveMQ broker?

How to connect to cloud hiveMQ broker?
I've tried something and it worked, but now it isn't working anymore.
Thanks in advance for helping.

Is this the public or your own instance on their cloud

I think it's my cloud instance.
It's one of the clusters that is shown in the left side of the screen when I login

Do you mean this console screen?

Yes. This one.

My NR MQTT config to access mine is

You'll need to fill in name of your instance and click on security to add in username/password

In "server", do you insert your TLS URI or Cluster URL??

Mine is my Cluster URL

13 Nov 13:06:01 - [info] *****************************************************************
13 Nov 13:06:01 - [info] Flows stopped in safe mode. Deploy to start.
13 Nov 13:06:01 - [info] *****************************************************************
13 Nov 13:07:27 - [info] Stopping flows
13 Nov 13:07:27 - [info] Stopped flows
13 Nov 13:07:27 - [info] Updated flows
13 Nov 13:07:27 - [info] Starting flows
13 Nov 13:07:27 - [info] Started flows
13 Nov 13:07:57 - [info] [mqtt-broker:hivemqBroker] Connection failed to broker: mqtts://6a37b76a917148c095bbd12ab6d7a20

Not working.

Can you connect using MQTT Explorer?

My setup in there is


Is MQTT Explorer this software:


Its the swiss army knife for MQTT work :slight_smile:

When I login to hivemq I see this

That URL is the one I enter in the config Server field

On the Security tab, the username and password are not the same as I use to login at
You can see the username on the Access Management tab, I don't see any way to see or change the password but you can delete and recreate the user.

I think it is not connecting

The message "disconnected from the server" keeps showin on the bottom.
I tried to activate the encryption but got the same message.

I don't have validate certificate enabled on mine

Same result.

at his point I think your instance is unavailable (or your using wrong username/password)

Unfortunately, I don't think there is any support for the free option but it might be worth going onto their forum and seeing if someone picks up on it

Or maybe see what this does!

DANGER though!
Maybe it'll delete and let you re-create (or maybe it'll just delete!!!!!)

I tried deleting the other cluster I have, can't create another one in this free plan.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.