iMAC serial port comunication

Hi , I've installed node-red on my iMAC and in my MacBook.
I normally work with Arduino with the IDE on /dev/cu.usbmodem144201 and /dev/cu/usbseriall-0001 for Esp8266.
In node-red I can't find these serial ports , I've tried to use the Arduino IDE with node-red , but the result it's the same.
Should I use a USB to Serial TTL converter ?

Thanks for the attention.
S.

Are you doing something where you can’t use MQTT? That’s how I communicate between esp devices and NR

No , I am looking to read the pin value. Simple...
I've installed serialport,and Arduino Palette ... but nothing.

Thanks

I believe the command ls /dev/{tty,cu}.* will list all of the serial ports on the Mac (my Macbook Pro isn't on right now so I can't test).

There doesn't appear to be a way to access the device via a fixed ID as there is on Linux with devices in /dev/serial/by-id/.

Thanks, in the Arduino IDE I've read the port to comunicate with the board , and in node-read I want to use the same ...
I use the command ls /dev/{tty,cu}.* and give me the port that I use in Arduino IDE , and it is correct.
I don't understand why node-red don't see these...

Remember that using the tty entry is blocking. So if it is open in the IDE, you can't open it in Node-RED or visa versa. At least that is my understanding. Not sure if you can use the cu entry, that seems to be for sending, not sure if it also recieves as I've not really used serial on a Mac.

Thanks. Yes I tried to close Arduino IDE and the result is the same ...
Thanks again

Remember that NR will open the serial port at startup so if the IDE already had it locked, you would have to close it and then restart NR.

Ok,I will try.
Thank you