Mac v2.0.2 Upgrade Not Showing Up

I upgraded my Mac Node-Red to v2.0.2. The console shows v2.0.2, but, the web browser pull down (hamburger, upper right) still shows v1.3.4?

Screenshots of console and browser, attached.

Which version is running?

Alan

hi @n61ab could try with other web browser. I just upgraded in MAC also:
Captura de pantalla 2021-07-22 a la(s) 11.52.07 a. m.
i use Google Chrome.

you could go to manage palette to view:
Captura de pantalla 2021-07-22 a la(s) 11.53.57 a. m.

Hi,

Refresh cache?

Restart shell from scratch?

Paul

Update:

I tried three machines, Mac:Safari, NUC Windows 10:Edge, and NUC Ubuntu:Firefox.

Same result on all three, they each show v1.3.4 on the Hamburger and on the "Manage Palette".

Mac Terminal console shows 2.0.2

If you kill the terminal, does the editor still run after a browser refresh?

How do I "Restart shell from scratch?"

Alan

Yes, terminal "killed", Node-Red continues to run.

I used the "install script" on the initial v1 and v2 upgrade....so have always had Node-Red as a service.

that tells me even though you have node-red 2.0.0 installed, you have another instance of node-red already running in memory.

If you know there is a service that runs node-red, I imagine stopping that will permit the console version to work.

I am not familiar with MAC so cant help any further.

Alan
open a terminal window and run

pm2 info node-red

It should show something like this:


Which - in my case - shows that NR is running and the scrupt path is /usr/local/bin/node-red

To stop it run

pm2 stop /usr/local/bin/node-red -- -v

Change the path (based on what your mac returned) and then restart it using

pm2 start /usr/local/bin/node-red -- -v

and see what is now shown in the dropdown

Thanks everyone. Problem Solved. I am so embarrassed!

I have two Macs. I figured out, I updated the first to 2.0.2 and was looking at the upgraded Mac's terminal, but.......I was connected to the other Mac, not yet upgraded via the Web Browser.

Sorry for taking up bandwidth on the forum.

Alan

1 Like