Missing labels in editor

It could be a bad package but it does look as though there is some file loss or corruption.

You might have to reinstall

Question, why are you sticking with a very old unsupported version? There are many compelling new features in 2.2.3 and even more so in 3.0.2.

Uninstalling the packages didn't work. It does seem like file loss and it does seem like I'll have to reinstall.
(Bonus issue: the node palette won't open)
I spotted a "Missing ENV var CONFIG_PATH" in the start logs, but there's no info on it. It's not in any settings or config files either. Found a few mentions to the same error here in the forum, but they either went unanswered or were solved by reinstalling.

And yeah, a newer version would be great. But though I'm looking after it for now, this is not my installation and I'm not that familiar with the setup yet. It was in the plans for later, after I finished moving back-end tasks to other servers. Also, the dashboard tends to lose formatting at the smallest change, so I assumed the upgrade would likely destroy it and require lots of patience to fix and bring back online.

Guess that's ahead of schedule now :person_shrugging:
(On the plus side, all the flows having been working as normal. It's just the editor that's unreadable.)

Thanks again for the help

I also have this issue - and I see it with a brand new docker install. Is there a flag or an env variable I'm missing? Don't see much here - Running under Docker : Node-RED

version: "3.9"
services:
  nodered:
    image: nodered/node-red:2.2.3
    restart: always
    environment:
      TZ: America/New_York
    ports:
      - 1880:1880
    volumes:
      - nodereddata2:/data

volumes:
  nodereddata2:
    external: false

Weird, it seems like it has to do with docker compose? (Which makes no sense). I fiddled with minimizing the difference between

  nodered:
    image: nodered/node-red:2.2.1
    ports:
      - 1880:1880

started with: docker compose up -d

vs running with docker:
docker run -it -p 1880:1880 nodered/node-red:2.2.3

I tried several version 2.2.1 / 2.2.2 / 2.2.3 -- all the same result.

The docker compose one have no data persistence, no env variables, no custom config, but still show this issue -- so can't be corrupted flow data or anything like that?

Will keep fiddling...

okay - it legit just went away.

I'm back to my original docker compose above and the issue is resolved. No idea what I did. My server/data configuration is the same as it was at the start.

Maybe clearing browser cache? I did that a bunch throughout my fiddlin - but the issue never resolved right after I did it.

Hi!

Glad yours cleared up on its own.
Mine remained broken through a week of fiddling (while I tested an upgrade on another device). I tried clearing the browser cache and using other browsers or computers, but no luck. Not sure if that means something else solved yours or if our issues actually had different root causes despite looking the same.
In any case, a complete reinstall of Node.js and an upgraded Node-RED solved mine.

Silver lining: It's all good and I get to work on a nicer editor now. (the right-click menus and the junctions really improve the experience)

Mines back! :slight_smile:

It just started happening again - I haven't upgraded or changed anything.

I tried clearing cache, and restarting node-red. Also tried a browser I don't normally use (firefox). That still showed the problem.

No dice.

Right, so, things done tonight:

  1. For other reasons, I moved my node-red storage out of a docker volume to a real mount point for better backups
  2. Since I did #1 I could docker compose down nodered then docker system prune -a
    ...which clobbered all containers/images/volumes I had on my system.
  3. A simple docker compose up -d re-downloaded everything and relaunched NodeRed

All works, config is in place -- labels are still borked. So not sure that "reinstalling node red" fixes this. Gotta be some bug or a configuration setting, right?

Are you using the latest version of node-red now?

Hey,

Sorry, I'm not very familiar with docker (just vaguely know what it does), but does that also rebuild node.js? Because I suspect my issue may have been something on that side and not on node red directly.

A bug is always a possibility, but I'm not sure it's about node red configs. Those should be kept in the settings file, and I haven't changed mine. Also, at the time, I tried running node red on an empty directory and the labels stayed gone.

Do tell if you manage to figure out what causes this, please. It'd be good to know what to avoid.

@Colin I am using nodered/node-red:2.2.3 off dockerhub

Just realized this only happens when I load node-red through my proxy (nginx). If I load it direct :1880 then the labels load.

There's nothing in the console or network tab to indicate an error/warning or that something didn't load over the network

I see some obvious differences in the network tab. going direct, I see a request to /locales/editor?lng=en-US which looks like it contains obvious translations.

When I load through the proxy I don't see that request. There are more than a few other changes.

Overall node-red works just fine, hard for me to tell what to look for in this context. Is there a way to enable console debugging?


Editing because: You have reached the reply limit for this topic, (but, hmm, maybe I can just edit this to reply to myself?)


I had listen 443 ssl http2; in my server definition

removed http2 and seems to have fixed it

1 Like

Talking to yourself is a sign of something I'm sure ... :smiley:

Yes, this is because I don't think http2 supports websockets. Least I think that's what it is, I know I also had to remove that from NGINX config. websockets requires http 1.1

re-confirmed i do not have http2 enabled on my nginx server. must still be somethin else.

You still getting an issue with that? I certainly get that just fine when going through my NGINX proxy.

Yep - it seems to come and go. I haven't pinpointed anything that temporarily fixes it though. Every few weeks now I've done a bunch of updating node-red / updating nginx / restarting all the services... then in the middle of all that (not immediately tied to a service update/restart mind you) it'll just start working for a day or two, then it'll be back.

It's super fun :slight_smile:

Sounds more like a system performance issue. Time to check some parameters on the system. It could be that something is causing temporary issues periodically.

I use Telegraf/InfluxDB/Grafana to monitor my server but you may have some other monitoring in place?

I mean node red works... does all the node-redy things it's supposed to do. Interacts with home assistant and mqtt just great.

The labels are just not there -- not sure what to monitor?

CPU, Memory, SWAP and maybe disk use. Not sure if you told us what device you are using and how much memory/resources you have.