Msg : "Error saving flows - msg : undefined undefined

#1

Hello Experts, We have been working on a Web App in bluemix(IBM Cloud) using node-red, recently we have started receiving an unexpected error with not much detail of what is wrong.
image

When we run node-red in IBM cloud, the flows are stored in cloudant database, we have noticed that the error appears when we add new nodes or new lines to existing nodes, like if there is a limit of data that can be managed by the deploy action.

Can anybody confirmed this, we are using cloudant lite free version, which give us:
20
Lookups
per second

10
Writes
per second

5
Queries
per second

1GB
Storage
limit

Maybe is something related to the database? is node red doing multiples writes when the deploy button is pressed?

Any help would be appreciated.
PD I have tried to check the logs and I don't see any meaningful information about the error.
Thanks

0 Likes

#2

There is also a per-document size limit. You are probably hitting that if it happens when you try adding more things to your flows.

0 Likes

#3

Hi have this error me too. I don't have only "inject" node and "debug" node on my flow, and I link both. No change I tried many different setup, option.

But, it's really basic... I don't understand the error:

3/1/2019, 4:56:55 PMmsg : undefined

undefined

3/1/2019, 4:56:57 PMmsg : string[20]

"Error saving flows: "

3/1/2019, 4:56:57 PMmsg : undefined

undefined

3/1/2019, 4:57:55 PMmsg : string[20]

"Error saving flows: "

3/1/2019, 4:57:56 PMmsg : undefined

undefined

3/1/2019, 4:58:09 PMmsg : string[20]

"Error saving flows: "

3/1/2019, 4:58:09 PM

msg : undefined

undefined

0 Likes

#4

is this also on ibm’s cloud or on your own machine. if it is your own machine what is it and please copy and paste the startup logs from node-red

0 Likes

#5

Thanks ukmoose for the time to reply

It's on IBM cloud (bluemix).

Simple error:
image

0 Likes

#6

second image error:
image

0 Likes

#7

and here, the node configuraiton:

I think it's about msg configuration
and.. the error same in the second node... because.. if a I push button to deploy only 1 node, the first one give a warning message. and the last one (Debug), give the error error: node not deployed..

it is the msg.. is not pass from first to second node.. missing config. .. probably...

0 Likes