🎉 Node-RED 3.0.0-beta.4 released

Great work.

I'm getting and "Unexpected error" when trying to change, create or delete key on flow_cred in project settings.
Firefox_Screenshot_2022-07-01T06-37-57.563Z

Hi. Would you mind raising an issue on GitHub so that we catch and fix this for the release? Thanks

This issue is still present @ my 3.0-beta.4 installation:

image

Not sure if this is related to the other importMap issue but I get this when I try and import:

Node-red is on a Raspberry Pi, the browser is Firefox on Windows 10.
Browser cache is set to clear when Firefox is closed.
Issue remains after both computers are rebooted, so I assume all caches are clear?

Unfortunately It's not cache related and is definitely related to the known issue.

Linux Mint 20.3 installed new beta 4
1 Jul 20:14:00 - [info] Node-RED version: v3.0.0-beta.4
1 Jul 20:14:00 - [info] Node.js version: v18.1.0
1 Jul 20:14:00 - [info] Linux 5.4.0-120-generic x64 LE

and opened up localhost:1880. It does not go into the editor. It seems to hang up before it loads my flows. No controls are loaded to do anything.

PR established: https://github.com/node-red/node-red/pull/3730

I'm having a similar issue after the upgrade

yes, I deleted the 'settings.js' file. Incompatibilities exists from old settings.js file on older versions. Now it displays nodes for editing.

There shouldn't be - otherwise we'd have highlighted such a significant breaking change. Will investigate (I have a strong suspicion on what it'll be)

2 Likes

Thx Nick. Anyway for me recreating the settings.js hasn't worked.

Well, to be absolutely honest here, I did not intentionally delete settings.js because of any error messages leading me to do it.

It was in fact a completely unrelated, vague and wrong peace of information I recalled.

So I was in no way on any trace here, it was pure luck (or coincidence :smile: )

The error loading the editor (where you get a blankish screen and Problem initialising 'monaco' code editor ReferenceError: monaco is not defined in the console) has been fixed in git for the next release.

The workaround is to ensure you settings.js file includes a codeEditor section under the editorTheme property. The current default settings.js file has this property.

editorTheme: {
    ...
    codeEditor: { lib: 'monaco' }
    ...
}
3 Likes

Wow ... the switch to "monaco editor and some related entries in settings.js" was what I vaguely recalled and what let me delete the file in the first instance. Mh ... Off to the lottery now. It seems to be my day :smiley:

Much thanks, as I have deleted the file and found success.

I do not need any credit at all @hp_apcc. I just felt like the blind hen which found a grain of corn. And blind I was.

@jodelkoenig,
I tried to delete my flow file at first, but that had no affect. I only deleted the js file after someone here had suggested that fixed it. It's all good. You may have seen my attempt at 'Monty Python-esque' humor.

1 Like

Since updating to beta4, I don't seem to be able to import any flows.
For example, if I try Import > Examples, and pick any flow, I get this error message;

loadex3

A search of c262ada8.d4cd7 does not locate any such node in my flows (I assume that refers to the node ref in the example flow).
The same thing occurs if I try to import a flow (that I have just exported) - same error - different node ref.

This did not occur in beta3 as I loaded one of Bart's example flows last night OK.

I can't see any errors in the browser dev console (although I'm not the best to check!), and nothing in node-RED log.
Tried clearing browser cache, and also when using a new incognito window. Also restarted node-RED.

Node-RED version: v3.0.0-beta.4
Node.js version: v14.19.3
Linux 5.10.103-v7+ arm LE on Pi 3B+

1 Like

Same here Paul, but if you look at earlier posts it's a known issue.

1 Like

Ah, the post above that says 'cannot import nodes'....
Not the best description :confused:

1 Like