Node-red container has disappeared from Docker, why & how do I retrieve it?

Not sure if this is the appropriate forum or category, but here goes:

I have a Synology NAS running Docker.

It was set up with containers:
Mosquitto MQTT

The Node-red container has completely disappeared!

The NAS was not in use at the time and I am assuming that Watchtower might be the culprit.

I do have Synology's Hyperbackup running so assume that I could retrieve an older copy of the container.

Or is there a better solution to save the many flows that have been created ?

Containers should be considered immutable. Nothing should be created/stored inside a container other than the program itself (ie. the node-red flows should not be stored inside the container). If the container is gone, then it is only a matter of spinning it back up.

How did you create the node-red container ?

OK, thanks.....

I created the container following an on-line tutorial which suggested creating a folder "docker/nodered".
Then the command:
"sudo docker run -itd --name="nodered" --restart=always --net=host -p 1880:1880 -e TZ=Europe/Zagreb -v /volume2/docker/nodered:/data nodered/node-red"

Looking at the NAS, there is a "docker/nodered" folder that contains many folders and files (suggesting that this is the data associated with the now missing Node-RED container?) .

So, what is the best way of installing a Node-RED container in Docker so that it picks up the existing data?

Having realised that the "docker/nodered" folder contained the floe data etc, I re-installed the node-red container and hey-presto, It's all up and running again!

Many thanks

1 Like

Do you mean you ran docker run again?

Hi Colin;

by " Do you mean you ran docker run again?" if you mean in the NAS terminal running the command

"sudo docker run -itd --name="nodered" --restart=always --net=host -p 1880:1880 -e TZ=Europe/London -v /volume2/docker/nodered:/data nodered/node-red"

then, yes, that's what I did.......and it far, all's good.

Still not sure why the Node-RED container vanished from Portainer in the first place, I'm thinking that Watchtower mis-behaved so turned it off.

Any thoughts?

Not really. Have you tried power cycling the device to make sure the container restarts?

Yes, all of the containers restart after a NAS power cycle.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.