Node Red Crashed On Me

Hey Folks.
I'm just learning how to use Node Red.
I installed the Nodes for InfluDB2. I tried to configure a InfluxDB2 Write and send one simple REAL tag to it. It allowed me to deploy it, then I lost connection to Node-Red. When I go to start it now, it says
[error] TypeError: Cannot Create Property 'data' on number '-36.34872055053711'

That s the value of the tag I was trying to send to InfluxDB.

I need to know now how to get Node Red running again so I can fix the issue.

Thank you for any advice...

There are commad line options
node-red --safe

Thank you!!!
That is what I needed.

I didn't know there was one specifically for influxdb2.

It's called Stackhero InfluxDB-v2 "WRITE" and "QUERY"
I have not been able to get them to work yet. However, its likely something I'm doing wrong.


That node has multiple unaddressed issues on its github page. It appears to be unsupported. Why do you not use the node that most people use, node-red-contrib-influxdb?

I will try it. I didn't realize the difference before I started using it. I'm using InfluxDB2 so I figured I needed the Influx-V2 Nodes.
Can I write to the InfluxDB2 with the influxdb node?

Yes you can, there are also examples on the nodes page:

Im still getting issues.

"HttpError: organization name " AVF" Not Found"

(AVF is the name of the organization I set up when I installed the InfluxDB software.)

Im simply trying to move a single Integer Value to the DB.

Iv been trying to get through this for a couple days now, so far, its not working for me.

Show us the data you are feeding to the node, and how you have configured it.

Here is what I'm trying to do. Move the FreezerF2 Value to the InfluxDB
Thank you for your assistance.

Show us how you know there is an organisation with that name. I haven't used influxdb v2 but this link suggests various ways to see that. View organizations in InfluxDB | InfluxDB OSS 2.6 Documentation

I went to my InfuxDB UI and I was able to see that I indeed did have it wrong.
I had it as Apple Valley Foods, It should have been Apple Valley Foods Organization.

I fixed it. Now the error is gone. I'm not getting any errors now! However, I do not see data in my InfluxDB. I think I should see it automatically when looking at my Data Explorer Page for the Bucket in question.

You posted earlier


Is that still what you have? If so then it is not correct.

I have tried as well.
msg.measurment as I could gather from the Help window on this instruction.
I have also tried leaving it blank. I still don't get my data in my InfluxDb
I'm guessing it's still not right.
Thank you for any guidance or advice you can / have given

In the measurement field you put the name you want to give the measurement, NOT the Node-Red property containing the data.

When you left it blank, you have to put the measurement name in msg.measurement. Since I can see nothing in your flow doing that then, as @ghayne says, you should put the measurement name for your data in the node.

Yes!!! It worked....
I see now. The Measurment was leading me astray, amongst other issues you have folks have so kindly helped me work through. The data is in my InfluxD UI now and working as I wanted. I had thought the NAME field was the Data coming in. Now I see, that is the Name of the NODE and the Measurment is the name of the data being passed.

Also, I had not set up the query properly in Influx but I have straightened that out now as well.

I'm an Industrial Electrician and PLC programmer in Industrial equipment over 20 years. Writing ladder logic and doing HMI applications. I've been trying to learn these newer methods now to keep myself from getting to old fashioned. I'm also trying learning javascript as I go.

The help from this forum has been great, especially to a new, rather ignorant user of the software. I really appreciate it.

Thank you

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.