Node Red Dashboard not visible on OpenVZ Server

#1

Hello everybody,
i have already installed node-red on my raspberry pi and it works really well. But i also want to controll my relais from everywhere else. I can not use portforwarding or anything else on my router. So i had to find an other way. So i rented a small OpenVZ server. Node-Red runs on it but i cant install the node red dashboard. I already tried to install it over PuTTy but it also didn't work. When i install it over "manage palette" the node appear but when the page is reloaded they are gone. Anybody knows how i can fix this? I'm new to this, so please be kind :slight_smile:

0 Likes

#2

Hi @goebelino

you need to update the version of node.js on there - 4.2 is too old.

What operating system have you got on there?

0 Likes

#3

It is Ubuntu 16.04 64 bit. This is the newest version they offer :frowning:

0 Likes

#4

As it is ubuntu, you could use our Pi install script to update everything (node.js, npm and node-red), plus setup node-red to run as a service - https://nodered.org/docs/hardware/raspberrypi

Otherwise, you can just upgrade the version of node from nodesource - https://github.com/nodesource/distributions#debinstall (which is what the Pi install script does). We recommend Node 8.x.

0 Likes

#5

Do yourself a favour and move the default SSH port from 22 to something else - that will stop most automated hacking attempts.

Also, for NR, make sure that your firewall settings are correct. I would also recommend using a non-standard port for Node-RED as well since we've seen hacking attempts fairly recently.

You haven't fully explained your architecture but you might consider keeping NR on the Pi and using the VPS simply as a proxy if all you want is access to the web interfaces. Then you can configure your Pi to only allow access from your local LAN and the VPS, nothing else.

You should also be making sure that you only use encrypted connections to and from the VPS, especially from the VPS to your home network.

0 Likes

#6

Thx knolleary and TotallyInformation :smile:
The scipt worked and the dashboard is enabled. I also changed the default SSH port the port for Node-RED and added a username and password.

I am a total beginner with this and you helped me a lot. I'll try to understand more now and hope to make my idea work :sun_with_face:

1 Like

#7

Great! We all started at the same place so always happy to help.

0 Likes