Node Red fails to open if I don't have internet access because of lack of material-icons

Hi all, how are you?

I'm making an application with node red and it has graphical interface, everything works fine if I have access to internet but as soon as I got disconnected the internet and remains only in my local network then node red fails to load and gives me the following message

[error] FetchError: request to failed, reason: getaddrinfo EAI_AGAIN

The UI nodes that I'm using are the node-red-dashboard nodes but note, I need this app to work without internet so I need help in solving this because node red looks for some repository on github.

Thanks in advance for your help.

If you don't use material design icons in you ui nodes, will node-red run while disconnected from the internet?

Well, right now I know how to change the theme between the installed ones but I don't know how to change the icons of the theme for use offline icons.

If you can point me to the right direction I'll be very gratefull

What version of Node-RED and node.js are you running?
What version of the dashboard node?
(You can get the answer for all of these from the startup log)

Please export your flow and attach it to a reply.

Use the fa-icons that are built in instead. There are less to choose from but hopefully enough to do what you want

1 Like

I'm using node-red v3.0.2, js v16.18.1 and dashboard version 1.0.2.

The flow is the following

Flujo.txt (21.6 KB)

right now I'm seeing that I possibly have a problem here because I have dashboard and dashboard-evi installed and apparently they use the same nodes in the pallete. I'll chek and I'll let you know.

I forgot to tell that I'm using a rpi 4

look, I uninstalled dashboard-evi and feezal, feezal was giving the following warning

21 Nov 22:05:55 - [warn] [feezal/feezal] TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. Received undefined (line:63)

after that the editor opens but when I try to open de /ui simply shows

Cannot GET /ui/

then I got feezal installed again but the

Cannot GET /ui/

remains and I can't show the /ui.

then I ipdated node red but the problem remains worse than before...

and feezal keeps giving me the warning

What is fezzal
What do you use it for?

I'm not using for anything and I don't know why is installed, I'm just using a few buttons, a gauge and Modbus nodes to communicate with a a PLC controller.

So, right now I don't have any clue of what's happening with node red for not showing the ui

Thanks @dceejay for your help but as you can see on the previous messages right now I can't load the ui and I don't know why it doesn't load.

Any help with that will be very appreciated.

I was asking about 'feezal' because you said you uninstalled it and it looks like it has been abandoned. So it is a good this you removed it. Also, as you found out, you can not have node-red-dashboard and dashboard-evi both installed.

There are two ways to open the dashboard

  1. use http://ip-address-of-node-red:1880/ui' for example

  2. in the NR editor dashboard on the right hand sidebar select the Dashboard icon
    Screen Shot 2022-11-22 at 7.15.46 AM

then select the little square with an arrow
Screen Shot 2022-11-22 at 7.16.04 AM

that will open the dashboard in a ne browser tab.

Does that work for you. If not, please open a terminal and stop and then restart node-red. Then copy and paste the startup log up to when you see
21 Nov 04:49:52 - [info] Starting flows

well, I normally open the dashboard writing the url on the web browser but as you suggested I tried by using the button on the sidebar and the outcome is the same, the browser shows the same message

Cannot GET /ui/

bellow is the log of node red installation on my raspberry,

Start Node-RED
Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser
Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot
To find more nodes and example flows - go to
Starting as a systemd service.
22 Nov 10:07:54 - [info]
Welcome to Node-RED
22 Nov 10:07:54 - [info] Node-RED version: v3.0.2
22 Nov 10:07:54 - [info] Node.js  version: v16.18.1
22 Nov 10:07:54 - [info] Linux 5.15.76-v8+ arm64 LE
22 Nov 10:07:55 - [info] Loading palette nodes
httpAdminRoot /
httpRoot undefined
22 Nov 10:08:05 - [info] Dashboard version 3.1.7 started at /ui
22 Nov 10:08:06 - [warn] ------------------------------------------------------
22 Nov 10:08:06 - [warn] [feezal/feezal] TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. Received undefined (line:63)
22 Nov 10:08:06 - [warn] ------------------------------------------------------
22 Nov 10:08:06 - [info] Settings file  : /home/global63pi/.node-red/settings.js
22 Nov 10:08:06 - [info] Context store  : 'default' [module=memory]
22 Nov 10:08:06 - [info] User directory : /home/global63pi/.node-red
22 Nov 10:08:06 - [info] Projects directory: /home/global63pi/.node-red/projects
22 Nov 10:08:06 - [info] [Dashboard] Dashboard using development folder
22 Nov 10:08:06 - [info] Server now running at
22 Nov 10:08:06 - [info] Active project : Motogen_7320MKII_SCADA
22 Nov 10:08:06 - [info] Flows file     : /home/global63pi/.node-red/projects/Motogen_7320MKII_SCADA/Flow 1.json
22 Nov 10:08:06 - [info] Starting flows
22 Nov 10:08:06 - [info] Started flows

the only different thing that I didn't note before that I see is the message about the dashboard using development folder, besides of that one of the first messages that shows the log is that the dashboard was started using the /ui suffix.

And again, the editor is working fine at least as I can see but the ui doesn't open.

How did you uninstall that node?

Oh it looks like that node gets installed using NPM. So you need to run
`npm remove dashboard-evi'
and then restart NR again

I installed dashboard-evi through the manage pallete menu, for that time I didn't know that node red came with a default dashboard installed, the problem is that I uninstalled dashboard-evi yesterday, just after that then I couldn't see the dashboard anymore.

So, following with the try to solve the problem and in ordeer to see if flushing the service then the problem colud be solved then I reinstalled node-red without uninstall it (more like an update) but id didn't work, right now I don't know if the installation of dashboard-evi partially crashed my system or not.

Another thing that I could see is that if I see in the manage pallete menu the state of dashboard-evi it says "conflict" in the status rectangle but I repeat, dashboard-evi is uninstalled since yesterday.

Finally I'm considering simply reinstall the whole OS and start again.

Certainly no need to do that. If you want to clear out all the stuff you have done with node red then simply rename the .node-red folder and restart node-red.

Before doing that, though, check in the menu Configuration Nodes select Unused and delete them all. Select them one at a time and click delete. Then look through and make sure there are no evi related ones there.


I have never seen that line in a startup. This could be a issue with the order of the multiple items you installed.

If you are going to start all over, you can go $HOME/.node-red and find your flow file and copy it to a external location before starting over. If you are going to reinstall the OS, why not use a new SD card so you have this if you want to explore ways of fixing it.

Thanks @Colin, this solved the problem of showing the /ui and apparently solved too the problems with the icons. Tomorrow I'll do a couple of test and see if anything changes

What solved the problem? Getting rid of unused config nodes?

Renaming the ./node-red folder and restart node-red solved the problem, after that I installed the official dashboard of node-red and everything worked again, I didn't have unused nodes before doing watch you suggested

1 Like

If you want to know why it failed then post the file package.json from the original .node-red folder.