Node-RED no longer installed in Rasbian by default?

#1

Looks like Node-RED has been removed from the default build for Rasbian. Not a big issue as it says it is now one of the recommended applications.

A new installer has been included for recommended apps.

Not tried this, just going from the release notes.

https://downloads.raspberrypi.org/raspbian/release_notes.txt

0 Likes

Raspi 3 won't install node red
#2

I’ve just setup a Pi with the new image and just used the curl script from
https://nodered.org/docs/hardware/raspberrypi

and its setup fine

0 Likes

#3

It will be interesting to see what version the Recommended applications install…will t be up to date or not. :thinking:

0 Likes

#4

Hi - this was news to us and we’ve spoken to the Pi guys to find out what’s happened.

Essentially they want to cut down the image size as it has grown and grown - which is understandable.

The Recommended applications install will still use apt-get to install things - so you’ll still get the version you would have done when we were part of the image.

Nick

1 Like

#5

So yes… a bit of a “gee thanks for telling us” situation going on.
As Nick says the “recommended software” app will install the apt packaged version (ie what is/was the current pre-install on nodejs 4.x…) - so the best thing to do is to ignore that and just use the install / upgrade script as per our docs.

This will of course then still show in their app as Node-RED not being installed (as indeed the package isn’t)… but for now you just have to ignore that “fact” and trust that you did install it and all is fine…

We will of course update the docs as soon as we work out what the best way forward is.

0 Likes

#6

I thought they probably hadn’t said anything.

Doesn’t really matter apart from needing to update the docs. In fact, it is probably better since they were already taking liberties with node.js by missing out npm to reduce the size anyway.

Thankfully Dave, your excellent and clever script solves all ills in any case which is why @cymplecy can carry on regardless. :wink:

1 Like