Node-red not deploying on IBM cloud

Hello, I have been trying to run a Node-red app on IBM cloud using the Node red start kit.
At first, it worked for a couple of days then I started getting an error saying that the requested route does not exist.
I tried with a second account but since the first try to add a node in package. json it builds but doesn’t deploy.
This is the error I’ve been getting (with the app still being empty) :

Error restarting application: Server error, status code: 400, error code: 100005, message: You have exceeded your organization's memory limit: app requested more memory than available

type: web
instances: 1/1
memory usage: 128M
state since cpu memory disk details
#0 running 2020-04-12T13:27:56Z 0.2% 99.5M of 128M 267M of 1G

The editor still works and I can deploy from it, but no new nodes and the status of the delivery pipeline remains “failure”

Any advice appreciated

As a Lite account user, you get 128Mb of free memory to play with. If you already have an app running using 128Mb then you cannot run another one until you stop the first. (Stopped applications do not count to the memory used).

Do you have more than one application created under this account?

No I dont have any other apps on the account

If you don't have any other apps, then it is very odd for it to be giving you that message. You aren't the first to mention getting this message - I'll flag it up with the team who manage the dev-ops pipeline to see if there is a wider issue here.

Thank you , I appreciate it .

Hi @basfa

could you try something for me? Could you go into the IBM Cloud page for your app and stop the application, and then try deploying the change?

I think what is happening is the toolchain is trying to deploy the new version alongside the old, before switching the HTTP routes over. But to do that, you need to have memory available to run the old and new apps at the same time.

I think if you stop the old app first (so its memory usage doesn't count), the toolchain will be able to deploy the new version.

1 Like

I tried it and it worked !
Thank you so much for the help .

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.