Node Red Not working ! Nodes not installing!

On the one that installed successfully, post the output from this command run in the .node-red directory
grep -i oled package-lock.json

@Colin, unfortunately, it's not here. it's in a unit build for a client a far-far way from here!

My post crossed crossed with Dave's, his is better advice anyway.

HI @dceejay and @Colin,

I have followed the instructions and can happily inform you that the SQLite node and OLED nodes are successfully installed and working !!! thank you

Now, I really need this captive touch keypad to work. I also use a bus port. Please help

Do you have a python script that accesses it? Some have had better luck with I2C using python and interfacing that to node-red either by running a script from an exec node or having a long running python script that interfaces to node-red via mqtt.

HI @Colin, no i don't have a script yet. i will need to look for one. I think that will be the best option to run the exec node ..not sure how yet with a keypad ?

I've just tried to install 'sqlite' (v0.6.0) and although it appears in the palette it won't run when I type...
$ sqlite3
on the command line. Gives the error -bash: sqlite3: command not found

I've tried uninstalling and installing using the command line - still no joy.

I'm using RPi-4B, NR v1.3.0-beta.1, node v12.21.0 and npm 6.14.11

Any guidance/suggestions would be appreciated.

To run it from the command line don't you have to install sqlite3?
sudo apt install sqlite3

Thanks Colin - I think that's sorted it.

Yes it has sorted it.