Node Red Not working ! Nodes not installing!

hi NIck @knolleary, There was no comprehensive startup log as usual,,

just this :

pi@raspberrypi:~ $ node-red start
9 Sep 13:13:08 - [info]

Welcome to Node-RED

9 Sep 13:13:08 - [info] Node-RED version: v1.1.3
9 Sep 13:13:08 - [info] Node.js  version: v12.18.3
9 Sep 13:13:08 - [info] Linux 4.19.118+ arm LE
9 Sep 13:13:14 - [info] Loading palette nodes
corrupted size vs. prev_size

Another issue i am noticing is that when i install a node , it shows installing and after a few min it stops and the button reads "install" and not "installed" as usual. as if noting happened. regardless of the node i am trying to install .

2020-09-09T12:11:02.504Z Install : node-red-contrib-oled 0.1.0

2020-09-09T12:11:15.169Z [err] npm ERR! code ELIFECYCLE
2020-09-09T12:11:15.169Z [err] npm ERR! errno 1
2020-09-09T12:11:15.229Z [err] npm ERR! i2c-bus@1.2.5 install: `node-gyp rebuild`
2020-09-09T12:11:15.229Z [err] npm ERR!
2020-09-09T12:11:15.250Z [err]  Exit status 1
2020-09-09T12:11:15.250Z [err] npm ERR! 
2020-09-09T12:11:15.250Z [err] npm ERR! Failed at the i2c-bus@1.2.5 install script.
2020-09-09T12:11:15.250Z [err] npm
2020-09-09T12:11:15.259Z [err]  ERR! This is probably not a problem with npm. There is likely additional logging output above.
2020-09-09T12:11:15.626Z [err] 
2020-09-09T12:11:15.626Z [err] npm ERR! A complete log of this run can be found in:
2020-09-09T12:11:15.626Z [err] npm ERR!     /home/pi/.npm/_logs/2020-09-09T12_11_15_510Z-debug.log
2020-09-09T12:11:15.685Z rc=1

No , now no nodes wants to install . shit!!!!!!!!!!!!!! :exploding_head:

So what errors do you get when you try to install a node on the command-line in the ~/.node-red directory?

so let's rewind a little if we can... let's try and clean up and step forwards

cd ~/.node-red
npm uninstall node-red-contrib-oled node-red-node-sqlite node-red-contrib-nfc

then install one at a time and report the results here

npm i node-red-node-sqlite

then repeat for the others...
then stop and restart Node-RED.

HI @dceejay,

Ok , let me do that. dont go far ..give me 5 min

@dceejay, ok successfully uninstalled ...respose :

removed 745 packages and audited 164 packages in 134.765s

2 packages are looking for funding
  run `npm fund` for details

found 0 vulnerabilities

Now I will try to install one by one as shown above

ok - do nfc last. hasn't been touched for 2 years and uses i2c which has moved on a lot since then... so that may the source of a lot of the problems.


OK, got it. the Sqlite is still busy installing ...will wait for it to complete, i know you said it will take at least 20min?

While I wait, do you have any advice on the Keypad / NFC / OLED that needs to be run by the same bus port? how does one go about this to make this work?

"The project I need to complete one's node-red is working again " below

(Keypad + LCD + RFID help needed / issue)

Sorry - I'm not that familiar with i2c - the hardware usually a jumper or switch or something that allows you to select an alternate address if necessary. I thought different bus meant different pins at the Pi end. eg see pic here

HI @dceejay,

no problem, I will keep on digging!

On the SQLite topic, still waiting. it is standing still for a long time on the same line ...

Ok @dceejay, SQLite installation is completed and restarted node-red and the Sqlite node is not in the toolbar ?

Never mind, after reboot it was working perfect !! thank you

npm i node-red-contrib-oled
npm ERR! code ETARGET
npm ERR! notarget No matching version found for oled-i2c-bus@^3.0.1.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget
npm ERR! notarget It was specified as a dependency of 'node-red-contrib-oled'
npm ERR! notarget

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2020-09-09T14_08_23_158Z-debug.log

HI @dceejay, It seems the other don't want to install ?

The node is broken. You could submit an issue on the node's github page.

I think we have been here before. There are already issues about that against the node but it appears the author has gone AWOL. There are suggested workarounds in the issues.

HI @Colin, why and how. I installed this same node this weekend on another PI and project, and worked fine?

No idea, sorry. As you can see the package.json calls for a version of oled-i2c-bus that does not exist.

@Colin, no worries mate,

Im just frustrated for something that worked and now all of a sudden nothing seems to work or install.

i have re-installed the OS and replaced the Pi zero with a new one, still nothing . its 38 hours straight now trying !!!!

ah yes - ISTR we have been here before a while back - I think the workaround was this -