Node-red on Fedora server

Hi guys
I have just installed Fedora 33 on an old PC and all running well. I have also just installed Node-Red using the bash scrip HERE and i cannot seem to access Node-Red from another PC on a local network using the http://serverIP:1880. I have have tried adding the 1880 port to firewall list on the server with tcp and upd protocols but still no luck.

Anyone know what other options i can try?


Does node-red work if you access it locally on the machine it is installed on?

Can you ping that PC from the other machine?

On the node-red PC run
netstat -tulpn | grep LISTEN
and check that port 1880 is open.

Hi Collin
Thanks for the response. Yes, am able to ping ip of server and Node red runs fine on local machine. I figured out how to add the node red service to the Fedora firewall through its web browser interface with root access and then it worked.

Thanks for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.