Node-RED UI does not show up

Hi Community,

I guess I need your support: How to start Node-RED-UI without flows running from the beginning?

I changed an existing flow and after a restart of Node-RED the Node-RED-UI won’t show up anymore. Using IP-address (192.168.x.x:1880) the browser shows “busy” and some minutes later only a blank page. Using Home Assistant’s Node-RED side bar it's the same. All other functions of Home Assistant are up and running.

Restart of Node-RED or of the whole system won’t change the behavoir. The logs doesn’t show any untipical entries. Status monitor of the system shows that Node-RED causes 28% of the CPU load! (RPi4).

That leads me to the assumption that I may generated an infinit loop with the last edit of one of the flows (I somehow looped back an output signal to input). I guess Node-RED could be too busy to start the UI? While Node-RED-UI won’t show up I can’t change the flow to solve the issue.

Any ideas how to avoid Node-RED is running the flows from the beginning?
I won't loose the latest changes.

Best regards - Marco

You should be able to start using the --safe flag. Eg

node-red --safe

Thanks for you reply dceejay!

I'm using Node-RED as an add-on in Home Assistant. I don't know how/where to add the parameter "--safe".

Are the flow information completly stored in the file flows.json? In this file I found segments containing "disabled":false.


What is the meaning of this "disabled"? Is it just that the TAB is not displayed or will the flows inside also not been processed?

Disabled will mean not running. Sorry I don’t use HA, so yes careful hand editing of the flow may be a way out. But back it up first.

Thanks dceejay. That helped to solve the problem. For others who might have the same problem some more information:

By mistake I created an infinite loop inside a Node-RED flow (connected output from nodeA to input of nodeB and output of nodeB to input of nodeA). After deploying the change this infinite loop caused a high CPU load on my RPi4. After a restart of the Node-RED add-on the user interface in Home Assistant never came up again. The add-on showed 28% CPU load instead of the normal approx. 1%.


I disabled the tab with the infinite-loop-flow manually and restarted the Node-RED add-on. The userinterface showed up again. Afterwards I could repair the flow and activate the tab again. - DONE :+1:

I used SAMBA to access the right folder (\\config\node-red\flows.json and opend the flows.json with an text editor (e.g. notepad++). At the very beginning I found
...,"type":"tab","label":"<YOUR TAB NAME>","disabled":false,...
I replaced the false with true to disable the tab, saved the file and restarted the Node-RED add-on.

The deactivated tab means that the flow will not be processed.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.